How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Canuck Tech Your Own Question
Canuck Tech
Canuck Tech, Auto Service Technician
Category: Car
Satisfied Customers: 532
Experience:  Red Seal Journeyman Technician, 20 Years experience
57969284
Type Your Car Question Here...
Canuck Tech is online now
A new question is answered every 9 seconds

Kia: While on Live Data on my scan tool I have a line pop in

This answer was rated:

While on Live Data on my scan tool I have a line pop in at the top that say"s "Fuel Sys 1 OL-fault" this seems to be triggered at the same time I get a STFT reading over 25 even though it is a breif reading.
The engine computer is no longer looking at the information from the oxygen sensor, at it is going into what is called open loop. Are there any trouble codes present? how does it run?
Customer: replied 3 years ago.

It runs really good, however it is getting a code of P1117. I am helping one of my wife's single mothers (she picked it out on craigs list) . it had a high idle problem.about 3000 rpms, the shop we got it from had changed the head. I change the idle control valve ....dropped rpms to 1500. Took the intake back off and re sealed all of the gaskets with old fashion Form a gasket no. 2. also clean the back side to the throttle plates. Once back together the Idle is at factory specs. Was driving it to get the computer to set so I could it to pass smog. At about 70 miles it triggered the P1117 code.Can't find a intake leak, but the STFT bounces all over...from 2 and3 to 10 plus then it hits 25 and that sets the ". Fuel Sys 1............OL-fault" line at the top of my Live data screen on the scanner. all of this takes place in the first minuet or so of starting the vehicle.

Customer: replied 3 years ago.

Just had a thought while talking to my wife. I also had to change a bad injector on this Sportage before I got the idle down, is it possible that there is an intake leak at the injectors? I have tried spraying fluids to find leaks but that area is pretty hard to get to.

Do you have the option of looking at long term fuel trim? The short term will bounce all over the place - it almost tracks with the oxygen sensor. I also need to know if we are talking positive fuel trim, or negative - I'm assuming positive, though. It is possible to get air leaks past the bottom injector seals, but there are other indicators and possible issues. If the idle is back down to where it should be, this is good, but what about the idle air control number? An air leak will have the idle air control number down at zero. Lean codes also show up because of low fuel pressure, a lying mass airflow sensor, or an ECT or IAT that is sending incorrect information.
Canuck Tech and 5 other Car Specialists are ready to help you
Customer: replied 3 years ago.

I will have to get back with you, hopefully this evening. Thank you.

Customer: replied 3 years ago.

I think I just sent you a long detail list of what I found when I got home and started the Kia , However I don't see it on my dialoge list. Have you recieve any extended information from me since about 545 pm Pacific coast time.

Customer: replied 3 years ago.

Ok I think I didn't send this correctly so I will enter it again.


I got home from work, went out and started the Kia with the scanner hooked in I got the STFT bouncin around a minus 16 to 21 ( I thought this to be positive, but paid closer attention after your question), the LTFT reading 17.9 , which is the only reading I have seen there, because I noticed yesterday when driving it that the LTFT seemed to be the only reading that didn't change. I then started to scroll down the list to get the other readings, of which follows, MAP 12.4 to 12.9 , the MAF .657 and that moved to .457 as the engine is warming up, TPS 10.1 to 9.8, 02S B1 (s1) .815 to .110, STFT B1 (S1) minus 25.0 to 0 and plus ,7 as it is warming up, 02S B1 (S2) .470 and STFT B1 S2 n/a. ONCE it hit 195 degress the STFT went to 0 and is staying there , all of this is being done at idle speed 800 rpms with one drop to 760. What have I got going on??

Sorry for the delay - I'll have a look at this in the morning. Canuck
Customer: replied 3 years ago.

Thank you.

What year and model is this car?

 

P1117 KIA - HO2S Circuit Low Voltage Bank 1 Sensor 2

 

Possible issues - Faulty HO2S Sensor Bank 1 Sensor 2, HO2S Sensor Bank 1 Sensor 2 harness is open or shorted, HO2S Sensor Bank 1 Sensor 2 electrical circuit poor connection

This is the rear oxygen sensor. Popped one of those in yet?

 

Canuck

Customer: replied 3 years ago.

No , but that will be my next step. The shop we got this from just had a new cat put in this 1996 Kia Sportage withXXXXX

Customer: replied 3 years ago.

If you can reply within the next 5 minuets , I will gladly rate you as a excellent ...headed out the door to work. If not will do so this evening.

Probably missed you - talk to you later. Best, Canuck
Customer: replied 3 years ago.

Im sorry, just got in.......one of those days ...if anything can go wrong it will. Good to at least end it on a good note. I will try to catch you again tomorrow . Once again thank you. Lester

No problem! Canuck
Customer: replied 3 years ago.

Are you available for a new question?

Same car or a different one? I'm not sure how this works from the other end - I think you can request me specifically, but I'm not 100% sure. Canuck

Customer: replied 3 years ago.

New question. same car. I feel you answered more than one question here and would like to rate you and get on to the next question.

Customer: replied 3 years ago.

Also once I rate you the question is finalized and I can at that time request you. but right now the system still has this question open. ......I need to close by giving you your rating.

Sure. I'm good for another question. I'm assuming you got the check engine light out?

Sure. I'm good for another question. I'm assuming you got the check engine light out?
Canuck Tech and 5 other Car Specialists are ready to help you

Hi - I can't answer that question directly because I'm not a "Kia" expert. I'm going to copy and paste your question, and we can figure out the technical stuff later -

 

Yes the check engine light is out. I changed the down stream o2 sensor. and once the vehicle was was the STFT stay at 0 and the LTFT is at 17.9 that has not changed at all during this hole time. The one concern I have now is I still have the "Fuel Sys 1..........OL-fault" is still at the top of my live data screen. I think at this point I am going to have to drive it till the computer resets and see if I get the P1117 code back or any others. So do you agree with this process or do you have any thing that I have messed up on? I will catch you later it is 855 time for a little r & r with the wife , will check back about 10 or so ..Thank you for your help and patience

 

I would go in and "clear" the codes. This should put everything back at the start point (0 in the case fuel trims) and then I would drive it. Can you access "readiness Monitors" with your scanner?

 

 

Customer: replied 3 years ago.

I will follow you steps. And the "readiness Monitors" blink until they are set....I don't think I can access them but I will find out. And Thanks Again.

TTYL. Canuck
Customer: replied 3 years ago.

Well I did run the process and am still going to have some questions, but at this time you have once again answered my questions with information that has helped me move forward with a very challenging project car.. Thanks again. Please respond so that I may rate and close this question. Lester

Thanks. Talk to you soon. Canuck
Canuck Tech and 5 other Car Specialists are ready to help you

Related Car Questions