How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask hilltop4527 Your Own Question
hilltop4527, Auto Service Technician
Category: Car
Satisfied Customers: 90
Experience:  Independent repair shop owner/operator experience with many makes and models both foreign and domestic.
Type Your Car Question Here...
hilltop4527 is online now
A new question is answered every 9 seconds

Ford transit: I have a 2000 ford transit van 2.4 Td the engine

This answer was rated:

I have a 2000 ford transit van 2.4 Td the engine check light came on and since then the van loss its power and would not go pass about 35 mph I have a few machanics check the van but they they cant seem to find the problem the diagnostic report have these numbers P1170 P0400 P0105 P0110 P1402 P1176 yet they at a loss thank you in advance for your knowledgeable response Bobby Thomas
Hi I see you are having trouble. I will try to help. I think you have a power supply problem , but that could be caused by the engine control module not sending signal to a relay, or a bad relay, bad fuse, or a shorted wire. Your problem is complex but I will do my best to assist you. The code P0105 refers to the map sensor circuit and P1402 refers to egr circuit. By looking at the schematic I see that these are fed by the same power supply. So we need to see if these sensors are receiving power. You can use a volt meter or a test light to see if there is power to these. The wire that feeds these is a red/black wire. Turn the key on and check for power at these 2 wires and we will go from there.
hilltop4527 and other Car Specialists are ready to help you
Customer: replied 3 years ago.

Hi hilltop thanks for your patience now i would like you to take me a little further if you can i had my elec check those wires as best as he can still dont have that pass 40 ish i really love my transit hope we can solve this problem thank you in advance 4527

Did he check the wires with a meter or test light to verify that they are getting power?
Customer: replied 3 years ago.

I am going to a better wire man to check this out on friday i am going to execellent so you get your credit but i sure need your guidance to get through this iwill be keeping you up to date thanks bro

Thank you for using Just Answer. Let me know what you find I will do my best to help.
Customer: replied 3 years ago.

He check the wires they are getting the power but he said the map sensor is not responding as it should so i am trying to get him one today so he can check it i keep you posted

Thanks and keep me posted
Customer: replied 3 years ago.

hi hilltop,

I finally found the problem, it was a plunger in the back of the epic diesel pump under the solonied. I changed and the light went off and the power was restored.


Thank you for your time and patience.


Bobby Thomas