How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Pete Your Own Question

Pete
Pete, Mechanic
Category: Car
Satisfied Customers: 15094
Experience:  15 years automotive training and experience.
Type Your Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Kia Sorento EX: i have a 05 kia sorento ex 3.5 v6 . It wont

Customer Question

i have a 05 kia sorento ex 3.5 v6 . It wont start just cranks over. i got power to fuel relay,and the relay seems to be working fine. i even switched it with the horn relay.that being said i dont have power at the inertia switch. but with the key on i have power to the yellow wire.should i have power to both red and yellow with the key on?thanks in advance im on day number six of trying to fix this problem. my wife had a battery installed and didnt drive it for a day then went out to leave and had trouble getting it to start .aftter she got home and parked it ,it hasnt started since.only fast crank.
Submitted: 1 year ago.
Category: Car
Expert:  Pete replied 1 year ago.
My name is XXXXX XXXXX X am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.

According to what I can see in the diagram for this vehicle it does look like the red wire should have power at this cut out switch as this leads to the fuel pump.If you have power on the yellow wire but not the red you may have a faulty cut out switch needing replaced.

If this switch has any kind of reset on it I would reset the switch and see if it resolves the issue.If it does not then the switch may need replaced to correct this.

Thanks Pete
Pete, Mechanic
Category: Car
Satisfied Customers: 15094
Experience: 15 years automotive training and experience.
Pete and 16 other Car Specialists are ready to help you
Customer: replied 1 year ago.
Thanks Pete for ur input. But shouldnt the red wire have power in the plug that plugs into the switch? Also i we jumped out the switch with no luck.How about the crankshaft sensor. That is what we are leaning towards because we have spark. So what do you think? Also it is not kicking out no codes. We had a new battery installed the day before this all happened. Is there anything from that, could cause these issuies.
Customer: replied 1 year ago.
Thanks Pete for your effort in resolving my problems. But the plug itself doesnt have power going to the inertia switch.Also we jumped out the inertia switch, with same outcome. We had a new battery installed the day before this all happened. Could that have caused any of these issuies? The old battery was dead for two or three mornings in a row so we had it tested and they said it was a bad battery. Which it was five years old so i figured that it was bad. We are leaning towards the cranshaft sensor but would like to have your thoughts and input first.
Expert:  Pete replied 1 year ago.
Hi,

I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.

Thanks Pete
Expert:  Pete replied 1 year ago.
What yellow wire do you have power on?

Let me know,thanks Pete
Customer: replied 1 year ago.
Hey Pete, i have power going to the inertia switch by the yellow wire only when your cranking the vehicle over. No power to the red wire anytime.
Expert:  Pete replied 1 year ago.
You should have power on the red wire at the inertia/fuel cut out switch if the switch is operating properly when the key cranking over the engine unless this switch is faulty.If you jump yellow to red will the pump run and the vehicle start then?
Customer: replied 1 year ago.
No Pete it wont run when jumped over.The tach isnt moving while cranking over either. Does that mean crank positioning sensor?. Also ive read about the engine light should come on when key is turned to the on position. And mine dosent. I did something that made it cone on the other day but only for a bit.i also scanned it while it was on and still no codes. Or is it a bad ground somewhere? Im puzzled and appreciate your help.
Expert:  Pete replied 1 year ago.
Do you hear the fuel pump run at all when you jump it or when you leave the swich connected and turn on the key or has fuel pressure been tested at all?
Customer: replied 1 year ago.
Hey Pete, i have power going to the inertia switch by the yellow wire only when your cranking the vehicle over. No power to the red wire anytime actually after another test i have no powr to the inertia switch at all. Also the four fuses above the starter relay has no power with the key on. Its injection o2 up, o2 down and one other. On inertia switch that was while cranking rhe car over.yes u can hear it sometimes like when the engine lifht came on while troubleshooting the other day. But now aftre light went off i dont seem to hear it. It never wsd really loud anyway. Bur we pulled it out and jumped it and it worked.
Expert:  Pete replied 1 year ago.
O.k.,the Main Relay provides voltage to these fuses here.If this relay has failed or is acting up this can cause this type of fault.This relay looks to be located in the under hood fuse/relay box near the battery.If possible tap on this relay or swap it out and see if the vehicle then starts and runs properly.This relay provides voltage to the fuses you have listed above.

Thanks Pete
Customer: replied 1 year ago.
Ok after switching relays it still dosent start. Its cranking over but still no start. I sprayed alittle starting fluid into it and it starts so we have fire. Im thinking its a ground somewhere. What do u think or crankshaft sensor?
Expert:  Pete replied 1 year ago.
Usually the crank sensor will cause a no spark issue and it sounds like you have spark here so I dont think this is the case here.

Does the main relay click with the key on or when cranking over the engine and when you swapped it out was it swapped out with the correct part number relay?
Customer: replied 1 year ago.
ok i checked the relay. Yes i swapped it with one of the same numbers.but as far as feeling it click with key on and while cranking,it is not.
Expert:  Pete replied 1 year ago.
O.k.,unfortunately I am at a loss on this one here.

I will opt out and put this question back on the list to see if others can help more.Don't reply to my last post here unless it is a last resort as it will keep the question locked to me.I hope you can get this resolved with ease.

Thanks Pete
Expert:  mastertech29 replied 1 year ago.
you need to see if you are getting power to the fuel pum. If you are the fuel pump is bad easy way to check is hit the fuel tank while someone is cranking the engine if it starts the pump is bad please let me know if you need anything else
Customer: replied 1 year ago.
no im not getting power to the fuel pump. I pulled it out and wired it straight and it works. The four fuses above the start rslay dont have any power its injecter,o2up,o2dn,and ecu.i know p/trn fuse is what tells the main relay to engauge which then guves power to those fuses to work. Stabdby and ill check.the p/trn fuse to see if its got power.thabks for your response. Im on day number seven missing with this thing.
Expert:  mastertech29 replied 1 year ago.
no problem, keep me posted I am here to help
Customer: replied 1 year ago.
yes i do have power to the p/trn fuse. I found someone on here that had my exact issues and Randall answered.for them. By what he says one of three things the ecm has failed,main relay failed,which i swithed it with another one with same outcome and or a wiring problem. Where is the ecu and how can i check it?. I really appreciate any and all input in this matter.
Expert:  mastertech29 replied 1 year ago.
there is no wat to test the ecu unless you send it out but it is located under the dash on the left hand side
Customer: replied 1 year ago.
idk if this will help but i did locate the tccu (transfer case control unit) under the carpet in passenger floorboard and found water and one wire that had broken and came out of the middle plug. We cleaned everything and resoldered the wire to the little prong that it broke from and cleaned everything with denatured alcahol and reinstalled with no change but like i said maybe it might help you on your end. Sounds like a bad ground to me somewhere but i guess tomorrow ill get the dash apart and acess the ecm and see if i can find anything out of place.yhanks for your help

JustAnswer in the News:

 
 
 
Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.
 
 
 

What Customers are Saying:

 
 
 
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P Elm City, NC
< Last | Next >
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P Elm City, NC
  • used your service this weekend with "Trecers" help. thank you ,thank you, thank you. replaced an A/C fan motor. Local Auto Zone had part. $15.00 "tracer" fee and $40.00 for parts, I saved several hundreds of dollers at a shop. i will recommend you and use you in the future. David L. Richmond, TX
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil Marysville, CA
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles Walnut Creek, CA
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
    Sue Charleston, WV
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff. Jim Castleberry, FL
  • The nearest Volvo dealer is 160 miles away. Best $15 bucks I have spent in a long time! Paul M Corpus Christi, TX
 
 
 

Meet The Experts:

 
 
 
  • Chris (aka-Moose)

    Technician

    Satisfied Customers:

    846
    16 years of experience
< Last | Next >
  • http://ww2.justanswer.com/uploads/MU/muddyford/2012-6-13_1204_1.64x64.png Chris (aka-Moose)'s Avatar

    Chris (aka-Moose)

    Technician

    Satisfied Customers:

    846
    16 years of experience
  • http://ww2.justanswer.com/uploads/TE/TedG/2012-6-15_14759_avaLarge.64x64.jpg Ted G.'s Avatar

    Ted G.

    ASE Certified Technician

    Satisfied Customers:

    1596
    20 years auto repair experience, ASE Master Tech, Mechanical Failure consultant, Expert Witness
  • http://ww2.justanswer.com/uploads/joecamel90/2008-11-13_03615_head_shot.jpg George H.'s Avatar

    George H.

    ASE Certified Technician

    Satisfied Customers:

    1311
    ASE Master Tech 15+ yrs, AAS Automotive Technology, Factory trained Asian specialist
  • http://ww2.justanswer.com/uploads/AM/amedee/2013-10-24_23656_Amedee1.64x64.jpg Amedee's Avatar

    Amedee

    ASE Master Tech

    Satisfied Customers:

    2367
    ASE Master Tech advanced level specialist
  • http://ww2.justanswer.com/uploads/SU/supermechanic/2013-8-23_03546_500.64x64.jpg Jerry's Avatar

    Jerry

    Master Mechanic

    Satisfied Customers:

    1906
    ASE master, 30+ years. All makes and models. Trouble shooter, shop forman, service manager
  • http://ww2.justanswer.com/uploads/CR/crzydrvr00/2013-11-3_12123_246347.64x64.jpg Richard's Avatar

    Richard

    ASE Certified Technician

    Satisfied Customers:

    942
    12 years Ford Lincoln/Mercury Jaguar dealership as a technician and shop foreman reparing all makes
  • http://ww2.justanswer.com/uploads/ST/Steve7654/2012-6-5_215929_japic800x660.64x64.jpg Steve's Avatar

    Steve

    Auto Service Technician

    Satisfied Customers:

    1980
    25+ yrs experience as a professional working technician; ASE L1 master technician