How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Technician
Category: Car
Satisfied Customers: 24142
Experience:  17 years automotive training and experience.
Type Your Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Mercedes-Benz C200: I have a C200 wagon, w202 1997 ,automatic,

This answer was rated:

I have a C200 wagon, w202 1997 ,automatic, when I start the car in the morning and starts up perfectly ...idles for 2 seconds and stops. I restart the car three or four times before I can leave the garage. The car is also very powerless especially when I go arund a corner ...come off the accelerator and than get back to speed up...there is a hole of a few seconds before the car regains power. some days I can go full throttle without the engine going over 3000 rpms. I have done a service, new spark plugs, oil, air filter, cleaned the air mass sensor with a special "air sensor cleaner" and made sure all leads are good and tidy.
My name is XXXXX XXXXX I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.

From what you have described here this may be due to a lack of fuel to the engine.If there is a lack of fuel this will cause this type of fault here and is usually caused by a failure of the fuel pump assembly itself.If the fuel filter wasn't replaced when the service was done I would start with this as sometimes this can restrict and may cause this type of fault here.The fuel pressure should be checked if the fuel filter has already been replaced or if it is replaced and the fault is still present.

Thanks Pete
Customer: replied 3 years ago.

Hi Pete

I have replaced the fuel change.

The pump is not an option as far as I would know...either works or not. That's right?

What about the fuel pressure regulator?



The pump can operate but may not be supplying the correct fuel pressure or volume as I have seen occur before,this can cause hard or no starts and lack of power when accelerating.My info isn't real clear on this regulator on this model whether it is on the engine fuel rail or with the pump assembly but if the regulator is failing it can cause this here as well.I would start with having the fuel pressure tested to see if this is a possible weak fuel pump.

Thanks Pete
Pete and 3 other Car Specialists are ready to help you
Customer: replied 3 years ago.

Thank you.

Your welcome.Let me know if you need anything else.

Thanks Pete

I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.

Thanks Pete
Customer: replied 3 years ago.

I have responded to you and clicked the happy face with payment instructions.

Did you receive that?

I did and thank you.I will close out this question.

Thanks Pete
Customer: replied 3 years ago.

Hi Pete


just an update about my car and its progress....

it was the fuel pressure regulator and the MAS sensor.

I have replaced both and the car runs like never before.



Thats great to hear the problem has been located and resolved.Let me know if you need anything else in the future.

Thanks Pete

Related Car Questions