How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Your Own Question
Tom, ASE Certified Technician
Category: Car
Satisfied Customers: 25920
Experience:  ASE Certified Master Technician
Type Your Car Question Here...
Tom is online now
A new question is answered every 9 seconds

rover range Rover: Range rover 6/2004, 4.4 , 128,000 miles.

Customer Question

Range rover 6/2004, 4.4 , 128,000 miles. DTC 1170. Please help. patrlck. XXXXXXXXXX
Submitted: 3 years ago.
Category: Car
Expert:  Tom replied 3 years ago.
Hi I’m Tom and I’m here to assist you with your issue today. Before I get you a fully researched answer, I have to ask you a couple preliminary questions. = Front heated O2 sensor no inversion (stuck).
It means that the signal isn't increasing like it should. Most likely the O2 sensor is bad. It could also be a short or that the wires aren't plugged in all the way. Could also be a cracked weld at the cat...or a vacuum leak, but that's will throw p1171/p1174 codes were these checked?
Customer: replied 3 years ago.
Hello and thank you
the radiator is out of the car .I hope to be running by thursday . i did not see or sense any cracks at the converters. i will scan the oxygen sensors and report back.

i am notvery savy on the computer . can this program be done on the phone ? Thank You Pat
Expert:  Tom replied 3 years ago.
Unfortunately it has to be done here site rule. I will continue with you until the end here.
Customer: replied 3 years ago.

I need your help on the rover but i can not getback upstream . I have freeze frame data and i can measure o2 sensors . please help me fix this car . pat

Expert:  Tom replied 3 years ago.
Ok so the o2 sensors are showing that there are not operating correctly is this correct?
Customer: replied 3 years ago.
I did not say anything about the o2 sensors . I said ihave freeze frame data when the 1170 code was set . Please tell me what you would like me to measure . Thank you Cardoctor for re-opening the communication door ! Pat
Expert:  Tom replied 3 years ago.
Not a problem can you post that data here?
Customer: replied 3 years ago.
thank you
Fuel sys. sta b1 cl.usingHO2S b2 cl, using HO2S. Calc. load 9.8% C00lant 210.1 S.T.F.T. b1 -1.57 L.T.F.T. 3.11 S.T.F.T. b2 -3.91 L.T.F.T.1.55 R.P.M. 1560 43.4 M.P.H. closed loop
Expert:  Tom replied 3 years ago.
OK from that reading seems like the O2 sensor 1 and 2 are not operating correctly these are the new sensors that are installed?
Customer: replied 3 years ago.
I have not installed any o2 sensors
Expert:  Tom replied 3 years ago.
OK from that reading thats telling me they are not operating .I would start with that next for this issue as long as the catalytic converter is not making noise .Remember that I'm here if you need any further assistance just let me know it will be for no further charge. Hoped this helped.Please rate excellent service so I can get Credit for my help thanks. Bonuses greatly appreciated

Related Car Questions