How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, Mechanic
Category: Car
Satisfied Customers: 39198
Experience:  Hi, I have been a Car/vehicle mechanic 34 years. 29of -running my own repair/diagnostic business.
9261905
Type Your Car Question Here...
Mike is online now
A new question is answered every 9 seconds

Suzuki Xl7: 2007 suzuki xl7, instrument cluster gauges drop

Customer Question

2007 suzuki xl7, instrument cluster gauges drop out, air bag light comes on, tire pressure light blinks, key fab not responsive, and radio cuts out. Very intermittent codes u0155,u0172, u0184, and u0214, loss communication with IPC, Rollover sensor, radio and Remote Function Actuation. Any suzuki techs or gm techs out there that can help I would appreciate it.
Submitted: 3 years ago.
Category: Car
Expert:  Matt replied 3 years ago.
Hello


1st thing I'd check is the main battery connections are tight an clean and the voltage level of the battery as this sounds like low battery voltage to me

don't forget to check the condition of the engine earth strap as well


Also check that the alternator is actually charging the battery in the car by taking a battery voltage reading with the engine off then another with the engine running. The 2nd reading should be higher than the 1st and climbing steadily. And also check that the alternator is secure to the engine as this provides the ground for the charging circuit and make sure that the engine / gearbox earth strap is secure and the contacts are clean and bright.

if the alternator appears not to be working - take it to a electrical specialist and ask them to test it as sometimes you can replace just the diode pack and this will repair the alternator without requiring replacement

Customer: replied 3 years ago.
BATTERY VOLTAGE IS 12.5 WITH ENGINE OFF AND 14.4 WITH ENGINE RUNNING. PERFORMED VOLTAGE DROP ACROSS ALL GROUNDS ALL AT .020 VOLTS. FOUND GMLOW SPEED LINE AT A STEADY 2.51 VOLTS WHEN PROBLEM HAPPENS, AND AS FAR A I KNOW IT SHOULD PULSE TO WAKE THE MODULES. THIS IS THE REASON I REPLACED THE BCM.
Customer: replied 3 years ago.
Relist: Other.
NOT THE PROBLEM
Expert:  Matt replied 3 years ago.
Ok I'm going to have to opt here and get another expert involved

good luck
Customer: replied 3 years ago.
THANKS
Expert:  Mike replied 3 years ago.
Hello and Welcome to justanswer..

My name is MIKE -

I see you have done a lot already - and inc basic electrical system tests -

Can I just ask - do you have definitions for each of the fault codes you have?

Too- how did this occur .... was anything done at the vehicle at all - jump starts etc ...?

Rgds, MIKE...........................................
Customer: replied 3 years ago.
Started eliminating one module at a time on the gm LAN low speed circuit. Now I'm down to going around the ip fuse block. So far so good I will let you know.