How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Auto Service Technician
Category: Car
Satisfied Customers: 23617
Experience:  25 years of experience, Certified Subaru Technician and Nissan factory trained.
Type Your Car Question Here...
Mike V. is online now
A new question is answered every 9 seconds

suzuki forenza: 2006 suzuki forenza 2.0 coming up with a P0300

Customer Question

2006 suzuki forenza 2.0 coming up with a P0300 code, changed out plugs, wires and coil pack still same problem
Submitted: 3 years ago.
Category: Car
Expert:  Mike V. replied 3 years ago.
Greetings phillip and welcome to JA! I will do my very best to assist you with your problem.Does the engine run rough at idle?How many miles on this?
Customer: replied 3 years ago.

yes it runs rough at idle and it has 160.000k

Expert:  Mike V. replied 3 years ago.
Ok, I would check a couple of things with this.First, with the engine running spray some carb cleaner around the intake to check for vacuum leaks. If the idle smooths out or the idle speed increases, then you know there is a vacuum leak at the manifold.Next, I would check the timing belt. With that many miles, it's possible it may have jumped a tooth or two and that can cause the problem.If this all checks out good, then try pulling the O2 sensor out of the exhaust ahead of the converter. If the idle smooths out, then there is a blockage in the converter that may cause this issue.Hope this helps!Please be sure to let me know if you need further assistance. If not, please be sure to rate my answer.Thank you.