How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Your Own Question
Tom
Tom, ASE Certified Technician
Category: Car
Satisfied Customers: 25950
Experience:  ASE Certified Master Technician
3827149
Type Your Car Question Here...
Tom is online now
A new question is answered every 9 seconds

Van starts fine, throttle down only revs to 15 after several

Customer Question

Van starts fine, throttle down only revs to 15 after several revs, it will slowly rev up. When driven there is no power, uphill is no power at all
Submitted: 3 years ago.
Category: Car
Expert:  Tom replied 3 years ago.
Is the engine light on?How many miles on the vehicle?
Customer: replied 3 years ago.
170000
Expert:  Tom replied 3 years ago.
Is the engine light on?
Customer: replied 3 years ago.
No
Expert:  Tom replied 3 years ago.
Does it feel like an exhaust restriction?
Customer: replied 3 years ago.
No, it wasn't something that was permenant, but it is now.
Expert:  Tom replied 3 years ago.
Ok so its possible there is an exhaust restriction now correct?
Customer: replied 3 years ago.
Like what?
Customer: replied 3 years ago.
Defo no blockage
Customer: replied 3 years ago.
Hello
Expert:  Tom replied 3 years ago.
Sorry lost internet connection.If fuel pressure is good has to be and accelerator pedal position sensor issue or TPS issue.It can even be a ECU issue.I would check these next.
Customer: replied 3 years ago.
How can I test the accelerator pedal sensor
Expert:  Tom replied 3 years ago.
You would need a scanner hooked up to the vehicle to see if its actually operating a meter will work but will not give the correct reading.
Customer: replied 3 years ago.
Ok, we will try all in the morning, thank you.
Expert:  Tom replied 3 years ago.
Anytime.Remember Im here if you need any further assistance for anything at all just let me know and we can continue for no further charge .Please rate excellent service so I can get credit for my help thanks.Bonuses greatly appreciated.
Customer: replied 3 years ago.
The actual problem was an air inlet sensor.
Expert:  Tom replied 3 years ago.
Why was this rated poor service. I was working with you and you never got back to me with the results. That rating affects me more then you know. If you can change that rating it would be greatly appreciated. Also if you need to continue tiniest for anything else at all just let me know. Also if that sensor was bad the engine light would have been on are you sure the engine light system operates correctly. Again sorry for any inconvenience but I would have continued with you to solve this issue.