How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Mike Your Own Question

Mike
Mike, Mechanic
Category: Car
Satisfied Customers: 38667
Experience:  Hi, I have been a Car/vehicle mechanic 34 years. 29of -running my own repair/diagnostic business.
Type Your Car Question Here...
Mike is online now
A new question is answered every 9 seconds

I am having a really bad time trying to find a fault with my

Customer Question

I am having a really bad time trying to find a fault with my express Van and would like someone to point me in the right direction.
Situation
Fuel gauge past the high point (pump works fine, have removed pump assembly)
Fuel pump wont prime when I turn on ignition ignition ( sender seems ok)
Checked harness at pump assembly and all connections are good
No indicator light on Park or Neutral until I remove the PCM connector C2 then returns but gas gauge does not return to normal and fault does not clear.
Battery drains down quite quick like I have a short somewhere.
Any suggestions would be really helpfull

Thanks, Ben
Submitted: 1 year ago.
Category: Car
Expert:  Mike replied 1 year ago.
Hello and Welcome to justanswer..

My name is MIKE - Im happy to help you with this..#

To start -

Can you please give me full details as to the vehicle in question -

Too - have you had any actual plug in tests done via its diag socket -and if so, with what results?

Rgds - MIKE........................................
Customer: replied 1 year ago.

Hi mike thanks for your help these are the original codes


 


I can't connect the obd when the intermitant fault shows up and the gas gauge goes beyond high when the fault gone and can conect the obd now has no codes maybe cleared from removing neg from battery ?


This all started driving home one day and the gas gauge went crazy and and it seemed to be missing or something


Parked up then would not start initially but would start intermitantly after that it seems it would start only when the fuel pump primed when i turned the ignition on


Gm codes :P0608, P0650, P1504. Generic code: P0650

Customer: replied 1 year ago.

Hi Mike


 


I was using blackberry earlier and hard to type so here is the full details


Chevy 2001 G2500 Cargo Van, 5L (Express)


Problems/Symptoms


-Engine will not start when ignition Key turned and fuel pump doesn't prime. When the pump primes the engine starts. Also note either way it does turn over.When it did start it seemed like it was missing or something and I had to rev the engine to keep it going.


-Gas Gauge past full(when fault is present)


-Speedometer did not work or waved around


-Red lights Park, reverse and Neutral lights not lighting up although D,1,2,3 will light up when I move the gear lever over. note :when I remove the C2 Red connector from the PCM ALL lights work fine.


-At the fuel pump assembly every thing tests out ok and I am thinking about putting it back in the tank.


Pump works when given 12V, Ground good, relay works fine and the resister attached to the float works fine when the fault goes as it is intermittent. I now have the float assembly out of the tank so when the fault goes I can move the float and the gas gauge does slowly rise although when I move the float to the full position the gauge will only read 3/4 full.


-when fault shows the OBD will not connect


-When the fault is not there the OBD will connect but there no data because I think I pulled the battery and cleared.


-There is also something strange on ground 451, PIN 1 on the PCM red connector, Pin 5 on the Data link connector. It is a ground and grounding but seems like there is a mili voltage there.


Mike, I am an electrician by trade so I am good with the basics but don't have extensive knowledge of auto electrical


 


Original fault codes


Gm codes :P0608, P0650, P1504. Generic code: P0650


 


I originally thought the cluster was done, but it and the connectors seem ok. It seems like something is groundig out somewhere, maybe a sensor or something.


I was starting to look at the speed sensor but don't no where it is could it have grounded out.


 


Regards,
Ben


 


 


 

Customer: replied 1 year ago.

I re connected a main ground to the engine block and that has resolved the Park, neutral light issue, they all work now on the cluster. Still have the intermittent gauge problem. From the codes I hope you can point me in the right direction.


I am a bit concerned as I have not heard back as this is my third post

Expert:  Mike replied 1 year ago.
Hello there Ben -

First my apologies for the delay here, Im afraid I have been off ill for a time so Im really sorry about that ..

Ok - with this - certainly the grounding was the original fault - and then that in itself, can have caused a fault with either one or the other - or both the main Ecu / Pcm...and the cluster...

What happens - as you will know being into electrics, well at least with vehilces, when the main ground fails for whatever reason, it will then "use" the next in line so to speak - and often this , because of the high current / in the circuit as it were, burns out the tracks on the Pcbs and / or components - again - on the main ecu / pcm - computer module ..and often the cluster.

So with this - as it is where you are now Ben, you are going to need to have these tested. To be honest - I feel the fault will be with the main ecu module rather than the cluster given what you have described.

There are companies that specialise in the test and repair of these ecu modules - it takes special equipment - you can test them with pin / meter tests or plug in diagnostics on the vehicle - not when the issue is suspected internally .

So thats the way forward on this one now Ben Im afraid - you have done a lot - all that you can do so far without that being done... Im sure from what you have described in excellent detail, that the fault will be found there... Usually they can be repaired which is considerably cheaper than a replacement - plus you can then refit it - no coding issues / costs. Google will likely be your best method to find a company near you or where you can dispatch the ecu to for test / repair - Let me know how you get on Ben.... and once again, my sincere apologies for the delay.

Let me know if you need anything more on this at all -

Meantime -- Please click on the OK rating to Excellent ratings service for me now, Thank you for that... and you can get back to me anytime if you need / wish..

Best Rgds, MIKE.


Please note, you are rating the content of my "answer" - my help to you - not the "system" which can experience delays etc which are not under my personal control -or delays caused by "time -off" which we all have on occasion - Thank you.


Customer: replied 1 year ago.

Hi MIke


 


I think the cluster is OK and will get the pcm checked out and get back to you,


 


Thanks


 


 


Ben

Expert:  Mike replied 1 year ago.
Hello again Ben -

Thank you for your reply..

Yes that is what I believe with your case here - so that is definately your next move and that should see this cured for you -

...... Can I just ask that you please click on the OK > Excellent ratings service now Ben at this point as that is how Ja credits me for helping you ... and Thank You in advance for that...

Nb -- Clicking on the Ok ratings as above does not close you out - you can get back to me at any time at all should you wish / need...

Kind Rgds - and all the Best -- MIKE.
Customer: replied 1 year ago.

Hi MIke


 


I have a fault somewhere as the battery keeps draining down and i dont think I should get the pcm and cluster looked at until I fix the fault. I pull out the radio fuse and the trans fuse and they both turn of the cluster speedo and P,R,D lights its weird. They shoud be completly seperate circuits and both are connectd to the cluster and pcm ?? any ideas

JustAnswer in the News:

 
 
 
Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.
 
 
 

What Customers are Saying:

 
 
 
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P Elm City, NC
< Last | Next >
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P Elm City, NC
  • used your service this weekend with "Trecers" help. thank you ,thank you, thank you. replaced an A/C fan motor. Local Auto Zone had part. $15.00 "tracer" fee and $40.00 for parts, I saved several hundreds of dollers at a shop. i will recommend you and use you in the future. David L. Richmond, TX
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil Marysville, CA
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles Walnut Creek, CA
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
    Sue Charleston, WV
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff. Jim Castleberry, FL
  • Excellent reply, and also very quick. Really sounds like the Expert knows what he is talking about. I will be back to use your service when I need more help with my RV. Dutch USA
 
 
 

Meet The Experts:

 
 
 
  • Chris (aka-Moose)

    Technician

    Satisfied Customers:

    846
    16 years of experience
< Last | Next >
  • http://ww2.justanswer.com/uploads/MU/muddyford/2012-6-13_1204_1.64x64.png Chris (aka-Moose)'s Avatar

    Chris (aka-Moose)

    Technician

    Satisfied Customers:

    846
    16 years of experience
  • http://ww2.justanswer.com/uploads/TE/TedG/2012-6-15_14759_avaLarge.64x64.jpg Ted G.'s Avatar

    Ted G.

    ASE Certified Technician

    Satisfied Customers:

    1596
    20 years auto repair experience, ASE Master Tech, Mechanical Failure consultant, Expert Witness
  • http://ww2.justanswer.com/uploads/joecamel90/2008-11-13_03615_head_shot.jpg George H.'s Avatar

    George H.

    ASE Certified Technician

    Satisfied Customers:

    1311
    ASE Master Tech 15+ yrs, AAS Automotive Technology, Factory trained Asian specialist
  • http://ww2.justanswer.com/uploads/AM/amedee/2013-10-24_23656_Amedee1.64x64.jpg Amedee's Avatar

    Amedee

    ASE Master Tech

    Satisfied Customers:

    2367
    ASE Master Tech advanced level specialist
  • http://ww2.justanswer.com/uploads/SU/supermechanic/2013-8-23_03546_500.64x64.jpg Jerry's Avatar

    Jerry

    Master Mechanic

    Satisfied Customers:

    1906
    ASE master, 30+ years. All makes and models. Trouble shooter, shop forman, service manager
  • http://ww2.justanswer.com/uploads/CR/crzydrvr00/2013-11-3_12123_246347.64x64.jpg Richard's Avatar

    Richard

    ASE Certified Technician

    Satisfied Customers:

    942
    12 years Ford Lincoln/Mercury Jaguar dealership as a technician and shop foreman reparing all makes
  • http://ww2.justanswer.com/uploads/ST/Steve7654/2012-6-5_215929_japic800x660.64x64.jpg Steve's Avatar

    Steve

    Auto Service Technician

    Satisfied Customers:

    1980
    25+ yrs experience as a professional working technician; ASE L1 master technician