How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mazda Ed Your Own Question
Mazda Ed
Mazda Ed, Auto Service Technician
Category: Car
Satisfied Customers: 2223
Experience:  ASE Master Technician, Mazda Master Technician, GM and Ford factory trained. 15 years experience!
Type Your Car Question Here...
Mazda Ed is online now
A new question is answered every 9 seconds

Main engine control relay buzzes ,new relay,have no spark,this

This answer was rated:

Main engine control relay buzzes ,new relay,have no spark,this is a 96 suzuki x-90,1.6 16valve

Is this a 2WD or 4WD so I can pull the correct schematics?
Does the check engine light come on with the key in the RUN position?
Do you have a meter or test light?
Customer: replied 3 years ago.

4wd,yes,i do have a meter and test light


With the key in the RUN position does the Check Engine Light come on?
Do all the electrical devices in the vehicle work, lights, radio, windows, door locks, etc...
Customer: replied 3 years ago.

yes,and yes

Ok here we go:

1) Measure the voltage at fuse #7 15A with the relay buzzing.
2) Remove the fuse and see if the relay stops buzzing.
3) Reinstall the fuse and remove the relay. Measure the voltage on the Black/Red wire
4) Measure the voltage on the Black/white wire.
5) Disconnect battery and check resistance of Blue/Black wire to a good ground.

Let me know what you get for these readings.
Customer: replied 3 years ago.

i dont have a computer in the garage i will have to do it then get back to you

That is fine! I'll be on for a little while yet and I will be on and off during the rest of today. If I miss your response I will get back to you as soon as I come back online. Don't rush! Just make sure all the results are accurate.
Customer: replied 3 years ago.

11.8 at fuse ,relay stops when fuse is removed,blk-red 0 volts ,blk-white 11.8 volts, resistance blue-blk 1.0k

Is that resistance 1000 OHMS?
Customer: replied 3 years ago.


When you checked the voltage on Black/Red did you reinstall the fuse (step 3)?
Also, I want you to check the ground wire that attaches to the back of the engine right below the PCV hose. Make sure this ground is clean and tight. Then check resistance from that ground to the negative cable of the battery.
Customer: replied 3 years ago.

ground is good ,resistance to cable is 7.0 ohms up&down some

Disconnect connector E33 (middle connector) at the Engine Computer.

OHM check pin 1 (black/orange) to ground.
OHM check pin 14 (black/green) to ground.
OHM check pin 1 to pin 14 (both are going to the ground #3 that you already checked on the engine)

Just checking in to see if there is any other information you need to resolve this problem.
Customer: replied 3 years ago.

pin#1 to grnd .9 ohm ,pin#14 to grnd .9 ohm ,#1 to #14 .4 ohm

Ok, At the main relay I want you to unplug it and jumper the Black/Red wire to the Blue/Black wire. This will bypass the relay. See if the check engine light still comes on with the key in RUN (this is important). Also see if the scan tool will communicate now.
Mazda Ed and 4 other Car Specialists are ready to help you
Customer: replied 3 years ago.

that didn't work but i did find the problem the main fuse looked fine but it wasn'nt [80amp] thanks any way .you helped alot .

I'm glad we found the problem! I'm not sure how fuse #7 could have had power with the Main fuse being no good... But at least its fixed.
Customer: replied 3 years ago.

that was the trouble it had partial power,i see alot of wierd stuff because i work on so many different things . thanks

Oh, ok!

Related Car Questions