How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask hilltop4527 Your Own Question
hilltop4527, Auto Service Technician
Category: Car
Satisfied Customers: 90
Experience:  Independent repair shop owner/operator experience with many makes and models both foreign and domestic.
Type Your Car Question Here...
hilltop4527 is online now
A new question is answered every 9 seconds

Kia Sportage: when i put the truck in 4x4 the light comes on

This answer was rated:

when i put the truck in 4x4 the light comes on and if i dont have in nutural ill hear it hit the gears.but while i have it in 4x4 the front wheels arnt turning with the rear
Hi I see you havent had any responses to your question would you like me to help?
Customer: replied 3 years ago.

yes i do need help.but i cant stay to answer ?s xmass shopping.but please do help

I hear you on the christmas shopping, I have been doing plenty The way your vehicle works is that when you put it in 4x4 it sends electrical signal to a solenoid that has vaccum(suction) lines connected to it.One line has suction which is created any time the engine is running and the other should not have suction until you put it in 4x4 mode. when the vehicle is placed in 4x4 mode a valve inside the solenoid moves which allows vaccum(suction) on both lines.This other line is connected to the front hubs and it sucks a gear in place to cause it to lock the hubs into 4x4.What I need you to do is to try to locate this solenoid, it should be mounted under the hood on the left side(PASSENGER SIDE) of the engine. You will see a small black canister with a small black rubber hose going in and coming out of it. Follow this hose when it comes out of this canister it goes directly into the solenoid.The solenoid will also have two wires running to it. Let me know when you find this solenoid. This could be a cheap simple fix. I will step you through some simple diagnostics to see if this is something you can fix yourself and save you some money. I look forward to hearing from you soon.

Customer: replied 3 years ago.

i see the vacuum lines and solenoid on driverside

Customer: replied 3 years ago.

i started truck and there is vacoom on one line none on other.i put in 4x4 and then i have vacuum on other i guess so far so step please

Ok the next step is to trace the vaccum line to the wheels and pull it off and see if you have vaccum there. I am not sure but you may be able to turn the wheels and reach these vaccum hoses without jacking it up and taking the wheels off. The hoses should just pull off you may have to get them twisting a little. if you have to jack it up be careful and use jack stands if you have them. Let me know what you find
Customer: replied 3 years ago.

well i cheated i used my hoist not into jacks lol also i used smoke machine and the passangerside smoke is comeing out of the hub

well it looks like you found the problem. The hub needs to be replaced.I hope I helped in some way. If so please leave me a positive rating and accept my answer so I may receive credit. Thanks
hilltop4527 and 5 other Car Specialists are ready to help you
Customer: replied 3 years ago.

hey boss i finaly gotten the hubs not to leak with smoke machine ( parts where not easy to get) i have vacuum but still no 4x4 what else should i look at. thank you

Do you feel it gear down when placed in 4 low?
Customer: replied 3 years ago.

i feel in go into gear when i put it in gear.and yes it took a few times but yes if i put into low gear i feel a change when moveing truck

I really don't know what else to check. If the transfer case is going into gear and the vaccum hubs are engaging I would suspect a broken cv axle but you should hear a loud thud while trying to pull out in 4x4 mode. You could also jack it up to see if the front axle is locking in. Maybe the vaccum isn't strong enough. Can you hook the vaccum hose going to the front axle to a strong engine vaccum some how and then test?
hilltop4527 and 5 other Car Specialists are ready to help you