How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Gary Your Own Question

Gary
Gary, Technician
Category: Car
Satisfied Customers: 10631
Experience:  GM master tech for 15 years/ASE master tech for 20 years
19513769
Type Your Car Question Here...
Gary is online now
A new question is answered every 9 seconds

Hummer H2: Hi, I have a 2003 Hummer H2 with 200k miles. The

Customer Question

Hi, I have a 2003 Hummer H2 with 200k miles. The truck cut out in the entrance to the gas station, I rolled up to the pump but after adding gas truck wouldn't crank with all the symptoms of low battery.
Here is a list of things I did after:
Tried jumping it, no change.
Tested the Optima Yellow Top batt, good.
Jumped the starter motor, engine cranks but no start.
Tested all fuses, good.
Tested starter and ignition relays, good.
Jumped the starter relay, engine cranks but no start.
Tested starter relay socet 86, no ground during crank ecm is not sending crank signal.
Tied reading OBD2, connection error.
Tested pink wire of ignition switch, powers on in pos. 2
Tested 2 pink wires to the ECM, hot when key in pos. 2
Tested all ground wires to ECM, all good ground.
Changed ECM for new one programed to my vin, no change.
Programed PassLock, no change.
Run PassLock test from manual, good.

Thanks,
Submitted: 1 year ago.
Category: Car
Expert:  FixItMan replied 1 year ago.

FixItMan : Hello, and thank you for letting us help you with your automotive question. Just to clarify, right now the engine does not crank?
Customer: Not with a key.
FixItMan : I'm not sure what you mean. What does the vehicle do right now if you try to start it?
Customer: Exactly
Customer: Dash lights up, I turn the key and everything dies down till I release the key.
Customer: Off for the weekend...? Opt- out....
FixItMan : Sorry. Having connection issues. Did you still want help?
Customer: Yes
Customer: Weekend is the only time i can work on it.
Expert:  FixItMan replied 1 year ago.
Our chat has ended, but you can still continue to ask me questions here until you are satisfied with your answer. Come back to this page to view our conversation and any other new information.

What happens now?

If you haven’t already done so, please rate your answer above. Or, you can reply to me using the box below.
Expert:  FixItMan replied 1 year ago.
Our chat session just would not work. Let's try this. It sounds like you either have a bad ignition switch or a problem with the vehicles power supply. You may have corrosion built up in the positive battery cable to a problem at the connection to the fuse panel. Have these items been checked?
Customer: replied 1 year ago.
What?!!! Coroded battery terminal!!!! You sure it's not my door mats? WTF did you read the question at all?
Expert:  FixItMan replied 1 year ago.
I am not sure if you read my answer correctly. I did not say battery terminal. I said inside of the batter cable. It is common to get acid inside of the cable, which will cause corrosion, which will cause resistance, which will cause a voltage drop and a loss of amperage. If this is how you plan on trying to get this vehicle running I will opt out and allow you to work with someone else.
Customer: replied 1 year ago.
Please do opt-out.
Customer: replied 1 year ago.
O and thank you for waisting 5 hours of my Sat.
Expert:  Gary replied 1 year ago.

new expert here did you still need help ?

 

Customer: replied 1 year ago.
Yes
Expert:  Gary replied 1 year ago.
ignition key on the check engine light is lit up in the dash cluster ?
does the horn work ?
if you put your meter on the big power wire that connects to the under hood fuse box what does it read for volts?
then when holding the key to crank what will that big power wire show when holding the key to crank ?
im sorry for the 20 questions but i want to be sure to give you the correct answer
Customer: replied 1 year ago.
Don't be apologetic, questions eliminate stuff, I'll try it now....
Expert:  Gary replied 1 year ago.
ok let me know
Customer: replied 1 year ago.
Check engine light dose not come on at any time.
Passlock light comes on and goes out 3sec after turning the key, then comes back one minute later and stays solid lit for 15+ min.

Big wire under the main fuse box in the engine bay gets 12.00v when key is turned to start position v drops to 11.88v
Expert:  Gary replied 1 year ago.
ok so when the ignition key on there is NO check engine light lit up on the dash cluster ?
Customer: replied 1 year ago.
No check engine light at any time, might have some thing to do with OBD2 scanner connection error that i mentioned in my original question...
Expert:  Gary replied 1 year ago.
ok with the key on in the under hood fuse box can you see if the fuses called PCM1 and PCMB show 12 volts on both sides of those fuses testing threw the little opening in the tops of those fuses inplace see if both show 12 volts on both sides of each fuse
Customer: replied 1 year ago.
Key in position 2...
PCM1 fuse 0v at both prongs, fuse good.
PCMB 12v at one, Bad fuse... Swapped it out for good one and tried to start the truck..... Engine started to crank but no start, i tried cranking again and now no crank, fuse still good with 12v
Customer: replied 1 year ago.
Progress owsome! :)
Expert:  Gary replied 1 year ago.
can you see if PCM1 will have 12 voltas both sides when cranking ?
is the check engine light on now when the key is on ?
Customer: replied 1 year ago.
Ok, truck cranks now 9 out of 10 tries,
PCM1 is 0v all the time... Position 2 and crank position.
Check engine light is on now and OBD2 connects good, no codes though.
Customer: replied 1 year ago.
Maybe try to learn passlock now again
Expert:  Gary replied 1 year ago.
when cranking is the theft light on or blinking ?
it bothers me that PCM1 fuse has NO power on either side when cranking or the ignition key on
Customer: replied 1 year ago.
Now it is, passlock light blinks when cranking and the fuel pressure is 0.... Sounds like anti theft system kicked in...
Expert:  Gary replied 1 year ago.
ok before you do the relearn i want you to check ALL the fuses visually one at a time and make sure NONE are blown
now do you have the old PCM still ?
Customer: replied 1 year ago.
I do have the old one.
Expert:  Gary replied 1 year ago.
ok put in old one and see if you get fuel PSI and make sure ALL the underhood fuses are NOT blown
Customer: replied 1 year ago.
Ok all thE fuses visually inspected in both boxes, all good.
Installed the old ECM and..
no fuel pressure
Pcm1 still at 0v
Crank but no start
Obd2 connects but no codes found.

The other I just noticed that the fuel gauge is not working.
Expert:  Gary replied 1 year ago.
ok try the relearn next and lets see what happens
  1. Turn ON the ignition, with the engine OFF.
  2. Attempt to start the engine, then release the key to ON, vehicle will not start.
  3. Observe the SECURITY telltale, after approximately 10 minutes the telltale will turn OFF.
  4. Turn OFF the ignition, and wait 5 seconds .
  5. Repeat steps 1 through 4 two more times for a total of 3 cycles/30 minutes , the vehicle is now ready to relearn the Passlock(TM) Sensor Data Code and/or passwords on the next ignition switch transition from OFF to CRANK. IMPORTANT: The vehicle learns the Passlock(TM) Sensor Data Code and/or password XXXXX the next ignition switch transition from OFF to XXXXX must turn the ignition OFF before attempting to start the vehicle.
  6. Start the engine. The vehicle has now learned the Passlock(TM) Sensor Data Code and/or password.
Customer: replied 1 year ago.
K
Customer: replied 1 year ago.
Passlock light went out after 5 sec and it didn't came back, I'm 5 min in to the first step..
Expert:  Gary replied 1 year ago.
ok so its more than likey learned already
let me look over a few scematics
in the mean time pull out the fuel pump relay and when you are holding the key cranking can you see if 2 terminal that the fuel pump relay goes into shows power when cranking
Customer: replied 1 year ago.
Fuel fuse good 12vFuel relay 87 has 12vCan you clarify, relays are up side down in my truck.
Expert:  Gary replied 1 year ago.

ok so 2 terminals show 12 volts when holding the key to crank ok

do me a favor put the fuel pump relay back in and remove the ignition 1 relay turn the key on and how many terminals show 12 volts ?

Customer: replied 1 year ago.
No only one #87 shows 12v...
Expert:  Gary replied 1 year ago.

if you turn the key off will that 12 volts go away ?

Customer: replied 1 year ago.
Yes

Customer: replied 1 year ago.
Ignition relay working properly.
Expert:  Gary replied 1 year ago.

ok so that shows the ignition switch is working the problem being we are missing the power to one of those terminals that should be power all the time and it gets it internall from inside the under hood fuse box

lets confirm the big power wire into the fuse box shows 12 volts.inside that fuse box its supposed to get that 12 volts to another terminal

lets try this.put the relay back in and jump 12 volts to the PCM fuse that had NO power at any time remember key on key off cranking ect..there was one PCM that showed nothing and the fuse was good.with a wire jump 12 volts to that fuse and see if the fuel pump will work and if it will start

Customer: replied 1 year ago.
Ok will do , FYI I piled a plug and there is no spark...
Expert:  Gary replied 1 year ago.

ok

that fuse PCM is power by that ignition relay it appears we are missing the power from inside the fuse box to the other leg of that relay to power up the other PCM stuff

Customer: replied 1 year ago.
Ok i jumped the PCM1 fuse to the battery and the engine went through its usual (now days absent) routine of clicks and noises then i cranked it and it started!!! But when i puled the key out of the ignition it stayed running till I puled the jump off.

Now i remember that few days after the breakdown the engine would still go through the clicks and noises routine but wouldn't crank...
Expert:  Gary replied 1 year ago.

ok the problem is that under hood fuse box is bad it is not sending 12 volts from the big power wire from the battery to that relay. If the wiring looks good under it replace that under hood fuse box and it should be fine

good work by the way testing everything !

Gary, Technician
Category: Car
Satisfied Customers: 10631
Experience: GM master tech for 15 years/ASE master tech for 20 years
Gary and 11 other Car Specialists are ready to help you
Customer: replied 1 year ago.
I'll let you know if it work out, thank you.
Expert:  Gary replied 1 year ago.
anytime
Customer: replied 1 year ago.
It was the fuse box. Thanks
Expert:  Gary replied 1 year ago.

any time!

good job

thank you for using Justanswer !

happy holidays!

Customer: replied 1 year ago.
Hi, I just noticed I have a subscription for another month.... Might as well milk it....

Truck is running fine minus one small detail. Anything with a light bulb in it pulses when the truck is on, regardles of rpms or speed the truck is moving with.
Did clean to metal grounds... Under driver door, on frame under driver headlamp and under hood next to brake master cilinder culdn't reach back of the block. Changing alternator had no efect on the problem.
Expert:  Gary replied 1 year ago.
just open up another question with this concern stated

JustAnswer in the News:

 
 
 
Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.
 
 
 

What Customers are Saying:

 
 
 
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P Elm City, NC
< Last | Next >
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P Elm City, NC
  • used your service this weekend with "Trecers" help. thank you ,thank you, thank you. replaced an A/C fan motor. Local Auto Zone had part. $15.00 "tracer" fee and $40.00 for parts, I saved several hundreds of dollers at a shop. i will recommend you and use you in the future. David L. Richmond, TX
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil Marysville, CA
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles Walnut Creek, CA
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
    Sue Charleston, WV
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff. Jim Castleberry, FL
  • Excellent reply, and also very quick. Really sounds like the Expert knows what he is talking about. I will be back to use your service when I need more help with my RV. Dutch USA
 
 
 

Meet The Experts:

 
 
 
  • Chris (aka-Moose)

    Technician

    Satisfied Customers:

    846
    16 years of experience
< Last | Next >
  • http://ww2.justanswer.com/uploads/MU/muddyford/2012-6-13_1204_1.64x64.png Chris (aka-Moose)'s Avatar

    Chris (aka-Moose)

    Technician

    Satisfied Customers:

    846
    16 years of experience
  • http://ww2.justanswer.com/uploads/TE/TedG/2012-6-15_14759_avaLarge.64x64.jpg Ted G.'s Avatar

    Ted G.

    ASE Certified Technician

    Satisfied Customers:

    1596
    20 years auto repair experience, ASE Master Tech, Mechanical Failure consultant, Expert Witness
  • http://ww2.justanswer.com/uploads/joecamel90/2008-11-13_03615_head_shot.jpg George H.'s Avatar

    George H.

    ASE Certified Technician

    Satisfied Customers:

    1311
    ASE Master Tech 15+ yrs, AAS Automotive Technology, Factory trained Asian specialist
  • http://ww2.justanswer.com/uploads/AM/amedee/2013-10-24_23656_Amedee1.64x64.jpg Amedee's Avatar

    Amedee

    ASE Master Tech

    Satisfied Customers:

    2367
    ASE Master Tech advanced level specialist
  • http://ww2.justanswer.com/uploads/SU/supermechanic/2013-8-23_03546_500.64x64.jpg Jerry's Avatar

    Jerry

    Master Mechanic

    Satisfied Customers:

    1906
    ASE master, 30+ years. All makes and models. Trouble shooter, shop forman, service manager
  • http://ww2.justanswer.com/uploads/CR/crzydrvr00/2013-11-3_12123_246347.64x64.jpg Richard's Avatar

    Richard

    ASE Certified Technician

    Satisfied Customers:

    942
    12 years Ford Lincoln/Mercury Jaguar dealership as a technician and shop foreman reparing all makes
  • http://ww2.justanswer.com/uploads/ST/Steve7654/2012-6-5_215929_japic800x660.64x64.jpg Steve's Avatar

    Steve

    Auto Service Technician

    Satisfied Customers:

    1980
    25+ yrs experience as a professional working technician; ASE L1 master technician