How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask proautotech Your Own Question
proautotech, Auto Mechanic
Category: Car
Satisfied Customers: 1243
Experience:  College Training. Current Lead Tech
Type Your Car Question Here...
proautotech is online now
A new question is answered every 9 seconds

Land Rover LR3: We have a 2005 Land Rover LR3. The radio displays

Customer Question

We have a 2005 Land Rover LR3. The radio displays "Phone Mode" and does not come out of that by pushing any of the buttons. It does come on occasionally but for very limited time. It also only comes on the first time the car is turned on. After that it does not work. If I take out the Amp fuse the radio works and the Phone Mode goes away but no sound comes out. I can change stations and everything but no sound. When it is in "Phone Mode" if I turn the radio all the way up you can here music but only very lightly.
Submitted: 4 years ago.
Category: Car
Expert:  Michelle-Mod replied 4 years ago.

Hi, I’m a moderator for this topic and I wonder whether you’re still waiting for an answer. If you are, please let me know and I will do my best to find a Professional to assist you right away. If not, feel free to let me know and I will cancel this question for you. Thank you!

Customer: replied 4 years ago.
Still waiting....._
Expert:  Michelle-Mod replied 4 years ago.

Sometimes, finding the right Professional can take a little longer than expected and we thank you greatly for your understanding. We’ll be in touch again shortly

Customer: replied 4 years ago.
still waiting for response.
Expert:  Walt-Mod replied 4 years ago.
Thank you for your patience, your business is very important to us, we are waiting on the Professional with the right expertise to come online. Feel free to let us know if you would like us to continue searching for an Professional or if you would like us to close your question. Thank you for your understanding!
Customer: replied 4 years ago.

Still no response......

Expert:  proautotech replied 4 years ago.
Thanks for trusting us with your problem. I have trained in the automotive field and currently work as a lead technician. I will be helping you today

This is a internal failure with the chipset on the radio itself. To fix the problem you have to replace the unit with a new or used unit.

I recommend a used one from to save on the cost a great deal.

I have only came across this issue one other time so it is not extremely common.