How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Your Own Question
Tom, ASE Certified Technician
Category: Car
Satisfied Customers: 25920
Experience:  ASE Certified Master Technician
Type Your Car Question Here...
Tom is online now
A new question is answered every 9 seconds

cold start runs rough..stall..only done 144thou klms light work.

Resolved Question:

6/1994 Exell.on cold start runs rough clouds of unburnt fuel and after warm up seems to be missing/intermittent....will occassionaly stall.has only done 144thou klms light work. I have had it scanned a couple of times without result.Any suggestions/?Andrew.
Submitted: 4 years ago.
Category: Car
Expert:  Tom replied 4 years ago.
Can you communicate with the ECM ? Was the mass air flow sensor replaced along with the headgasket ?
Customer: replied 4 years ago.

this model has air flow MAF sensor.head gasket not replaced Idont have scan tool to comm with ECM.

Expert:  Tom replied 4 years ago.
Ok air flow meter is the same as a mass air flow was this replaced ?
Customer: replied 4 years ago.
new plugs and leads new coil new crank sensor newfuel pump and filter and press.reg new oxy sensor. second hand flow metre s/h ECM s/h idle mostly runs well starts well lots of power..not running hot..using heaps of fuel..maybe 5 ks to the litre
Expert:  Tom replied 4 years ago.
Ok if this vehicle is dumping fuel you need to replace the air flow meter . This will cause this issue . I would start here does with a new factory o2 sensor.
Customer: replied 4 years ago.
Doc 74... I would agree with you re air flow metre BUT after the problem started it was the first thing I changed. yesterday I tried another metre...So how likely 3 metres are at fault. I would try a new metre if I could get one at reasonable price. Any clues?
Expert:  Tom replied 4 years ago.
It still can be an issue if the air flow meter is bad . Also does the engine light come on then go out for its self check when cycling the key?
Customer: replied 4 years ago.
doc 74you dont seem to be hearing what I am saying..I have been answering your questions you are not answering mine so I will just put up with the car as it is. thanks for your time.Andrew Philip.
Expert:  Tom replied 4 years ago.
Yes I have been answering yours . It's possible that each air flow meter if it's not factory is bad as well as a possible shorted ECM can cause this . These along with a faulty fuel pressure regulator and faulty coolant temperature sensor will cause this issue . Hoped this helped . Positive feedback and bonuses greatly appreciated.
Customer: replied 4 years ago.
are still not reading my responce to you...Ihave fitted new fuel press reg.I cant believe I have fitted 2 not including the original flow metres that are faulty. at those odds there wouldnt be a car on the road. I will give you points for the temp sensor... hadnt thought of that. it must now be the case that 2 accredited dealers have failed to scan/deffault the problem. so.. do I ask the EXPERTS to re scan for ECM short and temp sensor or dont the scan tool diagnose those.
Expert:  Tom replied 4 years ago.
Tell them just to physically test the sensor and send the ECM out to be tested properly where they actually open it up and check the printed circuit board.
Tom and other Car Specialists are ready to help you

Related Car Questions