How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Auto Service Technician
Category: Car
Satisfied Customers: 23617
Experience:  25 years of experience, Certified Subaru Technician and Nissan factory trained.
Type Your Car Question Here...
Mike V. is online now
A new question is answered every 9 seconds

1999 isuzu rodeo: dash lights..recently changed..lights went...does

Customer Question

I have a 1999 isuzu rodeo and the dash lights will not work. i had recently changed out my stero and the lights went out i pulled my stero thinking i crossed a wire but nothing change.does anyone know what i can do to fix this?
Submitted: 4 years ago.
Category: Car
Expert:  The Audi Doctor replied 4 years ago.

Thank You for choosing Just Answer for your query. Yes, I can help you.

You likely either shorted the illumination circuit and blew a fuse, or you hooked up the old illumination wire for the radio and it blew, and continues to blow the fuse.

The fuse should be #4 at the left side of the dash.

I suggest you check and replace the fuse. If it is not blown try changing the illumination level of the instrument cluster on the illumination rheostat. Did you turn it down by mistake.

If this does not correct the condition let me know and I will further assist you.

I hope I have answered your questions and addressed your concerns. Should you have further questions on this matter, please do not hesitate to ask. I want you to be 100% satisfied with my answer.

Positive feedback, referrals and bonuses are always APPRECIATED. If you accept my answer, please don’t forget to leave feedback.

Thank You!
Jake “The Auto Doctor”
Customer: replied 4 years ago.
I had already tried both of them before and nothing the fuse jumped across and the illumnation light knobe does not go up or down.when i pulled the dash and checked out the insterment cluster with the test light everthing was good but the the lights that i needed.When I put the test light on the illumination i have 3 wires two of them are hot the green with red and the red with green and the the last on nothing it makes me think i have 2 hots comeing in and one should be a ground.
Expert:  The Audi Doctor replied 4 years ago.
I have to go now so I am going to opt out so that another expert may help you. If you have not been helped when I get back I will try and continue.

Thanks Jake
Expert:  Mike V. replied 4 years ago.
Greetings Sir or Madam and welcome to JA! I will do my very best to assist you with your problem.
Hi there!
So, just the instrument panel lights are out? or all of them, the AT shift lights, hazard switch light, things of this nature? Or only the instrument cluster?
Let me know.
Customer: replied 4 years ago.
The shifter lights, ac lights and dash lights. But the lights are on like the high beam,the gear indicator on the dash things like that but the lights to actually see the gUages no.
Expert:  Mike V. replied 4 years ago.
Ok. Sounds good.
Let's go back to your switch.
Unplug the switch, then make a little jumper wire. Jump the black with the red/green and see if the lights come on. Probably not all will come on, but the gauge lights in the instrument cluster should.
If they do, replace the dimmer switch.
If not, let me know and we will take it from there.
Mike V., Auto Service Technician
Category: Car
Satisfied Customers: 23617
Experience: 25 years of experience, Certified Subaru Technician and Nissan factory trained.
Mike V. and 2 other Car Specialists are ready to help you

Related Car Questions