How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask CarQuestionGuy Your Own Question
CarQuestionGuy
CarQuestionGuy, Technician
Category: Car
Satisfied Customers: 1259
Experience:  ASE Master Auto Technician for 5 years, ASE Refrigerant Handler, ASA, iATN
8613158
Type Your Car Question Here...
CarQuestionGuy is online now
A new question is answered every 9 seconds

I took a 96 4.0 block and heads only and rebuilt it..intake..sensors

Customer Question

I have a 2000 disco II. I took a 96 4.0 block and heads only and rebuilt it, installed, with all of the 2000 model components such as intake sensors timing cover etc... and used  with 2000 crankshaft sensor and 96 flywheel. Engine does not spark or have  injector pulse. All else seems to work good. Fuel press at 45lbs. Scanner reads no data while engine cranks but shows data with out cranking. Scanner is in generic obd II mode only as I dont have chip for land rover. Has code showing P1501 and P0444. Evap hose broken for P0444. Iac not dx yet.  Is it possible that the 2000 crank sensor wont work with 96 flywheel. Also sounds like a computer issue if no data shows while cranking only. Thanks Dave
Submitted: 5 years ago.
Category: Car
Expert:  CarQuestionGuy replied 5 years ago.
Thanks for asking your question on JustAnswer. My name is Steve and I'll do my best to answer your question.

Did you check both flywheels to be sure they were exact matches?
I'm pretty sure the flywheel and CKP will not work from different years. My information is showing that these parts are not interchangeable.
I would check to make sure the wiring is all the same and that the sensor lines up with the flywheel correctly so it can read it, but I don't think it's going to work.

As far as the scan tool reading the computer, it won't read anything when you are cranking the engine. This is normal.