How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Neal Your Own Question
Neal, Mechanic
Category: Car
Satisfied Customers: 8349
Experience:  Auto repair pro and Mechanic on multiple makes.
Type Your Car Question Here...
Neal is online now
A new question is answered every 9 seconds

93 Chevy: distributor cap, rotor button, plugs, wires..hose..egr valve

Customer Question

I have a 93 Chevy pickup 305. It has a skip that will not go away. I have changed the distributor cap, rotor button, plugs, wires, PC valve and hose and EGR valve. It runs fine when driving but starts skipping bad at idle.
Submitted: 5 years ago.
Category: Car
Expert:  Neal replied 5 years ago.

Welcome to JustAnswer, I'm Neal and I am here to assist you.

Please feel free to ask follow up questions, it is part of the process.



That would be a bad IAC valve (Idle Air Control), it controls the air mixture only at idle so if that is the only time it is acting up that will be the problem.

Neal and 7 other Car Specialists are ready to help you
Customer: replied 5 years ago.
Neal You hit the nail on the head. I have one more problem maybe you can help me with. Its on the same vehicle. When I first start up and drive the truck the temp goes all the way up to approx 260 degrees befor the thermostat opens up. It has a new radiator, water pump and I switched from a 195 to a 180 thermostat, I also changed the fan clutch and both temp sending units.
Expert:  Neal replied 5 years ago.
Are you sure the thermostat is right side up? Don't take it wrong I don't know how experienced you are.

Related Car Questions