How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spire suzuki Your Own Question
spire suzuki
spire suzuki, Technician
Category: Car
Satisfied Customers: 358
Experience:  Suzuki master tech. 26 years in motor trade
Type Your Car Question Here...
spire suzuki is online now
A new question is answered every 9 seconds

Suzuki Aerio: ) I do not want to pull the engine unless Im

This answer was rated:

HELP PO335 Suzuki Aerio 2003 How can I be sure this part is NOT any good (how to test) I do not want to pull the engine unless I'm absolutly sure
Welcome to
The problem is crank position sensor related, the sensor is behind the alternator(generator)
there are only three wire for this component.
remove the alternator belt and push it back to gain access to the multi plug, disconnect the plug and check the voltages at the wires listed below with the ignition on
Red/ black battery positive 10-14 volts
Yellow/ black signal to engine control 4-5 volts
black/orange earth. 0 volts.
If all the readings are ok then you require a crank sensor
spire suzuki and 10 other Car Specialists are ready to help you
Customer: replied 5 years ago.
OK, those numbers are what i need, but someone else said the plug/sensor is in the bell housing area and that the engine will have to drop out to replace this sensor? can you confirm this? It looks like you are the Master!
Sorry i did not see the vehicle was a 2ltr engine, the readings are the same but yes the gearbox and flywheel have to be removed to replace the sensor, you can get to the multi plug but it's not easy.
Customer: replied 5 years ago.
is there a way to by-pass this sensor/ is it really needed? the car runs great, i just cant get my plates renewed with the light on the dashboard "on"

Hi Jack
Sorry for the delay.
The most common fault is a loose connection on the multi plug, to cancel the mil light disconnect the battery or engine control unit for 2 minutes and this will clear the fault code and turn of the mil light.
Customer: replied 5 years ago.
Thankyou, if i should have another question can i call on you?
Hi Jack
You can ask for me anytime, please direct questions to spriresuzuki