How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1044
Experience:  16 years of experience
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

my 97..believe that the tps is the culprit..garage..stumped

Customer Question

good morning after spending thousands
on parts for my 97 discovery land rover,
we now believe that the tps is the culprit but
when we installed it the idle stays at a high
rpm any suggestions we are desperate for
help my car sits in the garage because we've run out of money even the shop we took it to was stumped so we brought it home it's now 1 month and still not running properly.

thanks in advance
lydia and ron
Submitted: 5 years ago.
Category: Car
Expert:  Mechanic Martyn replied 5 years ago.

Hello and welcome to Just Answer.

If i understand you correctly the disco won't idle where it should - right?

Anything else?

What rpm does it run at?


Mechanic Martyn

Customer: replied 5 years ago.

thanks for responding Martyn


It flucuates at 1000-2000 rpm and no response from the throttle body when

you push the gas peddle. When you unplug the tps the rpm's drop

do any of the mechanics do phone consultations regarding problems

and then directed to just answer If we could get the rpm's to normal

perhaps I will be able to use my vehicle again, Initial problem was lack

of power up hills is how this all started, miss fires and rough idle HELP

Expert:  Mechanic Martyn replied 5 years ago.

Ok no problem

Unfortunatley we don't do phone consultations but we should be able to work through it from here.

Can you give me some detail on what else has been replaced please.

Also engine model.

I am going offline now for about 7 hours but I will be back after that.



Mechanic Martyn

Customer: replied 5 years ago.

thanks for your answer, here is the info you wanted

replaced cat converters, replaced fuel filter, replaced plugs, wires, cam shaft sensor,

all vacumm lines checked, all jets checked, all o2 sensors checked, all wires checked,

bought new throttle position sensor, this is where we are stumped the tps when

installed and vehicle started the rpms rev and will not kick down

97 discovery land rover sd 4.0 v8 engine with only 86,000 miles on it and never

had any kind of abuse off road.

We are now at our witts end and once we could get the revs settled I think that

I can once again drive this vehicle,

Thanks Lydia and Ron

Expert:  Mechanic Martyn replied 5 years ago.

Okay thank you for that.

I will give that a little thought and get back to you.

Did they look at the egr valve (exhaust gas recirculation.)

Also there is an Idle air control valve near the throttle body. The TPS sends information back to the vehicles computer to tell it about the throttle position. The computer uses that information and the information from the coolant sensor and the oxygen sensor and the crank angle sensor to set the position of the Idle air control (IAC) valve.

The IAC is only used for idle not anything above. You can try disconnecting it please at its wiring plug and the idle should drop.

I will consider the rest and get back to you. Please let me know what happens when you disconnect that wiring plug.



Mechanic Martyn

Customer: replied 5 years ago.
Relist: No answer yet.
Someone whould be able to help, or has
this problem stumped even the experienced
Expert:  Mechanic Martyn replied 5 years ago.
Hello again
Did you disconnect the IAC like I suggested?
Was there a result?
Mechanic Martyn
Customer: replied 5 years ago.

Hello Martyn,

Wel we took it to another mechanic and he replaced the iac motor and said that

the vehicle runs no better, He also did a smoke test and found a vacumm leak and

fixed that. It is now almost 4 months and two mechanics later and hundreds of dollars

and I still have no vehicle, we are in the process of bringing the vehicle home again

and will pick it up tomorrow when we pay off the bill. If I take it to a Land rover dealer

they'll probably re do everything that was done and charge me thousands more than the

vehicle i worth, All I do is sit and Cry all I want is my car to run correctly (sorry).

I do appreciate your help.

Lydia and Ron