How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1044
Experience:  16 years of experience
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

sending unit..My gauge..pcm reset..module

Customer Question

I just replaced an in tank fuel pump unit complete with the sending unit..My gauge is not working and I was told a PCM reset might be shop manual is not indicating how to reset the module? can you help? WHATS UP...i HAVE NOT GOT ANY RESPONSE YET??
Submitted: 5 years ago.
Category: Car
Expert:  Greg replied 5 years ago.
Hi welcome to will answer your question the best I can,

Did the gauge work on the old unit?

Regards Greg
Customer: replied 5 years ago.

no actually, it had very similar symptoms, i have read reviews of very similar problems with this car types....all I can find is that a PCM reset is recomended? I did perform the work with the battery disconected (ground only) The pump and all other functions are regarding the running of the car and engine lights etc are fine!

Expert:  Greg replied 5 years ago.
This has nothing to do with resetting the ECM .

I suggest you check for codes first and if you have any post them here for me to assist you further with this issue.

Kind regards Greg
Customer: replied 5 years ago.
I dont have the tools or means to check for codes....Is this all we can do?
Expert:  Greg replied 5 years ago.
hI ,

What i suggest you do first is pop down to Autozone for a free code readout .

When and if you have codes please get back to me.

Kind regards Greg
Customer: replied 5 years ago.
ok thanks...Am I being charged for your time with this?
Expert:  Greg replied 5 years ago.
There is no charge until i have helped you with this issue .

Please get me the codes if any for further assistance .

I am only paid for my assistance when you click on the accept button, but please only do this when you are happy with my service .

The accept button you will see when i think i have given you the correct info needed for this repair.

Info requestt ? waiting for more info from you.
Answer when i have finished or have given you the answer to your issue.

kindest regards Greg
Customer: replied 5 years ago.
Expert:  Greg replied 5 years ago.
Good let me know .

regards Greg