How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Former ASE Master Tech
Category: Car
Satisfied Customers: 24390
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Car Question Here...
Amedee is online now
A new question is answered every 9 seconds

Isuzu Rodeo why does my 92 isuzu rodeo run at high idle after

Customer Question

why does my 92 isuzu rodeo run at high idle after it warms up?
Submitted: 5 years ago.
Category: Car
Expert:  Amedee replied 5 years ago.
Hello and Welcome to Just Answer. My name is AMEDEE and I will try my best to assist you and your 100% satisfaction is my goal. I have been working on these vehicles for over 10 years so I am very familiar with this system and how they work. However, keep in mind, that I need some solid concrete facts/evidence/clues from you in order to give you a good answer about your vehicle. Please realize that all my answers are based solely on the info that you provide me with.


You might have an air or a vacuum leak. This is very common! Open the hood and listen for a hissing sound when the engine is running.
Unmetered air can enter the engine through a vacuum leak, a dirty airflow sensor that is not reading airflow accurately, an EGR valve is not closing and is leaking exhaust into the intake manifold, an EGR valve that is allowing too much flow.
If it is hard to pinpoint take some brake cleaner or starting fluid around the intake manifold and vacuum lines and see if the engine stumbles or if the idle is affected. Be extremely careful when doing this!

Also, your throttle body may be carboned up and need to be cleaned! This can cause all sorts of idle and hesitation problems. This is caused by the throttle plate not seating properly. The First thing i would do is clean out the throttle body with some throttle plate and intake cleaner and a small brush. Another common cause would be the Idle Air Control motor. This is very common on older cars. The IAC motor gets lazy and cant keep up with the fast idle changes. Also when the IAC motor is out, I rec to check the passages for carbon build up. If they are plugged they need to be cleaned out.



Check for the following conditions:



Poor connection at PCM or IAC motor. Inspect harness connectors for backed out terminals, improper mating, broken locks, improperly formed or damaged terminals, and poor terminal to wire connection.
Damaged harness. Inspect the wiring harness for damage.
Restricted air intake system. Check for a possible collapsed air intake duct, restricted air filter element, or foreign objects blocking the air intake system.
Throttle body. Check for objects blocking the IAC passage or throttle bore, excessive deposits in the IAC passage and on the IAC pintle, and excessive deposits in the throttle bore and on the throttle plate. Check for a sticking throttle plate. Also inspect the IAC passage for deposits or objects which will not allow the IAC pintle to fully extend.
Vacuum leak. Check for a condition that causes a vacuum leak, such as disconnected or damaged hoses, leaks at EGR valve and EGR pipe to intake manifold, leaks at throttle body, faulty or incorrectly installed PCV valve, leaks at intake manifold brake booster hose disconnected, oil filler cap, oil level indicator loose or missing, etc..


Possible Causes
Check for air leaks in the Air Induction system (e.g., in the intake manifold)
Check for air leaks in the PCV system and in its related hoses and/or valve
Idle air inlet passage or throttle bore is dirty or full of deposits
IAC valve has failed
MAF sensor is dirty, "skewed" or installed improperly
Throttle plate, throttle shaft or linkage is damaged or sticking
TP sensor is out-of-range or "skewed" high

Related Car Questions