How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1081
Experience:  16 years of experience
2499435
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Opel Caravan I have an Opel Vectra B 2,0 x20xev engine. The

Customer Question

I have an Opel Vectra B 2,0 x20xev engine.
The injectors are open too long.
25ms when i tray too start it.
the o2 sensor is new, airmas sensor is new water sensor, kamshaftsensor and kranckshaftsensoe is alsow new.
fuel presuer is 3 bar.
Can you help me?
Submitted: 6 years ago.
Category: Car
Expert:  nabilc replied 6 years ago.

Billy :

Hello and welcome to JA!!!

Billy :

I'm Billy and i will assist you with this.

Billy :

I appreciate the detailed info you put, but i would need some more:

Billy :

- what is the original problem......???

Billy :

- is the engine idling?

Billy :

- and in what conditions have you checked the injector duration?

Billy :

- do you have any warning lights on or flashing?

Billy :

Please include any symptoms or info, that might be relevant...........and we will sort this problem.

JACUSTOMER-89gfdpfa- :

the engine is not idling, the original problem it will not start.

JACUSTOMER-89gfdpfa- :

i have just change the injectors now, and it was not better. The warning light is on when i try too start the engine.

Billy :

did you check for the fault codes?

Billy :

And if the engine warning light is flashing while you try to start, then the problem is with the immobilizer system.

Billy :

And when trying to start, or when the starter is operating, it is normal that the injectors open for 25 ms or even more.

Billy :

The opening duration would be around 2 ms (from 1.8 ms to 3.6 ms), only when engine is warm and idling.....and not when starting....not when the accelerator pedal is pressed.....not when the engine is cold.

Billy :

Again, if the engine management light is flashing, when you are trying to start........it most probably is a problem with the immobilizer system........and for that, you may first try starting using a spare key.

Billy :

You may also check for any blown fuses, causing the immobilizer system to operate erratically.

JACUSTOMER-89gfdpfa- :

I checked the fault code, and there is not eny fault code. it is not the immobilizer system. The lamp is not flashing, and i checked the immobilizer system whit my tester. i have also using the spare key.

Billy :

If the sensors were replaced............and you checked for any blown fuses........and the immobilizer is fine......

Billy :

And no codes are present...........yet the engine warning light is on............you most probably have a faulty engine control unit.

Billy :

So first check the control unit and the respective connector.........it may have got water ingress or dampness........as it is located in the plenum chamber (under the windshield).

Billy :

Check the connector.........remove and check thoroughly and refit............check for any water ingress or dampness.

Billy :

Your engine management system is made by Siemens, and the control unit should be labeled: Simtec 56.5

JACUSTOMER-89gfdpfa- :

i have sent in engine control unit for a check, and it sculd be ok. it is a simtec 56.5 i also checked wires and the contackts and they seems too be ok. when i try too start the engine the injectortime sculd go down. i tryd on a 1,8 now and the injctortime started on 16ms and down

Billy :

you are able to program (or input the injector open duration)????.........in that case, make it around 20 ms, when starter is running......and then around 4 ms......until engine is warm.....then put it on 2 ms.

Billy :

And i have found a TSB (technical service bulletin), on your model, which causes the same problem, and is very relevant to your issue, so i will post it, so you check the details:

Billy :

It involves a faulty wiring........so check and fix if necessary.

Billy :

Regards,

Billy :

Billy

JACUSTOMER-89gfdpfa- :

i am not abel to program the injectors, i will check TSB now

Billy :

Check the TSB........and check the wiring involved.............if everything is up to norm..............then the next step would be replacing the ECU.............try borrowing and fitting for a few minutes......as if everything is fine, and the engine will not run.....it could only be the ECU.

JACUSTOMER-89gfdpfa- :

Hi, I have cheked the etc and it was ok, the ecu is new. the immobilizer will be a probleme if i borrow a ECU? Culd i juse a ECU from a 1,8 engine? it is the same system.

Billy :

You need an ECU from a 2.0 engine......

Billy :

With the same engine code......and same ECU code (simtec 56.5)......

Billy :

The immobilizer should not be a problem, when replacing ECU....

Billy :

But make sure you check the ECT wiring (the multiplug) and the wires and connectors as specified in the bulletin.....not only the ECT.

Billy :

do you need further info??? has the wiring been faulty, or was it the ECU>

Billy :

?

Related Car Questions