How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Neal Your Own Question
Neal, Mechanic
Category: Car
Satisfied Customers: 8349
Experience:  Auto repair pro and Mechanic on multiple makes.
Type Your Car Question Here...
Neal is online now
A new question is answered every 9 seconds

VL commodore..jump power,no ignition lights,its just dead

Resolved Question:

VL commodore tried to jump start it ,now their is no power,no ignition lights,its just dead could you please advise me on the problem
Submitted: 5 years ago.
Category: Car
Expert:  Neal replied 5 years ago.

Welcome to JustAnswer, my name is XXXXX XXXXX I'm here to help get your problem resolved. Please feel free to ask follow up questions, it is part of the process, thanks.


Check and clean your battery terminals. and check the grounds on the body and engine. Then try another battery in case yours is completely bad and is not letting current through.

Customer: replied 5 years ago.
all ready replaced battery and still nothing no ignition lights or power iam thinking that it might be computer if VL has one
Expert:  Neal replied 5 years ago.

I don't think it's the computer as it is affecting your lights also which are not part of the same system. Do you have the means to start tracing for power? A test light or a meter? I think you have a bad connection near the battery or a bad cable.

Neal and other Car Specialists are ready to help you