How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask vauxdoc Your Own Question
vauxdoc
vauxdoc, GM Europe master tech
Category: Car
Satisfied Customers: 1192
Experience:  25 years GM factory trained ATA UK registered
10908802
Type Your Car Question Here...
vauxdoc is online now
A new question is answered every 9 seconds

I have just fitted a new ignition barrel on my dads 51 plate corsa

Resolved Question:

i have just fitted a new ignition barrel on my dads 51 plate corsa and now it will not start. is it something to do with the imobilliser?
Submitted: 6 years ago.
Category: Car
Expert:  vauxdoc replied 6 years ago.
Welcome to just answer , can you tell me if the engine management light (EML) is flashing ? and is the engine turning over with the key ?

Let me know and i will help more. Regards XXXXX XXXXX
Customer: replied 6 years ago.
if the eml is a car with a spanner through it then yes it's flashing. The engine is turning over but nothing is happening. The new barrel just has standard keys with it but i kept the old key on the same ring as it's needed for the central locking. Cheers
Expert:  vauxdoc replied 6 years ago.
There is a black box with a black ring attached that goes around the barrel this is the immobiliser ECU is this the original and is the plug inserted correctly , the flashing EML is because the immobiliser is active.

Regards XXXXX XXXXX
Customer: replied 6 years ago.
it is the original unit and the plug is inserted correctly. It made a bleeping noise when i withdrew the old barrel.
Expert:  vauxdoc replied 6 years ago.
Ok I think I know what has happened , the immo. ECU ring has to read the immo. code from a transponder chip in the key , the replacement key has a wrong chip that the immo. does not recognise , pull the remote fob from the key base and you will see a small black chip remove and swap the original chip to the new key , loosen carefully with a craft knife and super glue it into in the new key.

Best regards XXXXX XXXXX
vauxdoc and 6 other Car Specialists are ready to help you