How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Auto Service Technician
Category: Car
Satisfied Customers: 23837
Experience:  25 years of experience, Certified Subaru Technician and Nissan factory trained.
2921078
Type Your Car Question Here...
Mike V. is online now
A new question is answered every 9 seconds

2001 Suzuki Esteem: Starting Fluid..a new fuel pump & fuel filter

This answer was rated:

My on Has A 2001 Suzuki Esteem 1.8, It Has No Injector Pulse It Is Getting Fuel, Spark And Will Run on Starting Fluid, No Codes in system, I put a new fuel pump & fuel filter on it. Where Does It Get Its Injector Pulse From and what could be the problem
Greetings Sir or Madam and welcome to JA! I will do my very best to assist you with your problem.
Is the vehicle getting activation on the fuel pump. Do you have fuel pressure making it to the injectors and how did you check for injector pulse?
Customer: replied 6 years ago.
The Fuel pump runs and builds pressure, i took the fuel line off at the injector bar and im getting good pressure, i tested the pulse with a noid light at all 4 injectors
Good deal! Any security system on this? I would check for a chip in the key and a security light and make sure they are acting normally
Mike V. and 2 other Car Specialists are ready to help you
Do you have a test light or voltmeter so we can check the harness for power and ground?
Did the noid light come on and just not p[ulse?

Edited by carguy1 on 10/2/2010 at 2:03 PM EST
Customer: replied 6 years ago.
this vehicle has no security system or chip on the key
I see that, does the noid light com on when you plug it in and just not flash?
Customer: replied 6 years ago.
Your Answers Didnt Really Do Me Any Good ( ill Accept It Any Way and figure my problem out on my own ) THANKS ANYWAY)
Well, if the noid light is lighting and not flashing,then you know you have power and ground. No light then no power or ground to the injectors. Check the black/red wire for power. Ground comes from the ecm. If you have power and no signal, inspect the crank position sensor as it may not be sending signal. No power, then you need to trace the wires back to the ignition main relay and check fuses. I suspect this is where the problem is going to be because it will run fine on starting fluid.
Sorry about all the questions but diagnostics is not a fast here is your answer kind of job. It is methodical and usually takes several steps.
Thanks for the accept although I feel I didn't help and we drop out in the middle of this.

Related Car Questions