How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Your Own Question
Tom, ASE Certified Technician
Category: Car
Satisfied Customers: 25920
Experience:  ASE Certified Master Technician
Type Your Car Question Here...
Tom is online now
A new question is answered every 9 seconds

2006 nissan maxima: abs light brake light are on..speedometer..tach

This answer was rated:

have a 2006 nissan maxima the gages are not working the traction light, abs light brake light are on. low fuel light on, speedometer does not work, tach does not work and a/c control panel not working
Ok was there any recent work done ? Was the charging system checked ?
Customer: replied 6 years ago.

has not been any work done as far as i know

the charging system is working

Ok have you had a charging system test done?
Customer: replied 6 years ago.

yes i did it

this a repair shop

i have limited info on this vehicle

Customer: replied 6 years ago.
it is charging 13.58
This is all usually caused by a coin falling in the display screen and shorting out the circuit board.Also have you checks the positive battery and negative battery terminals.If they are ok try disconnecting them for 15 minutes and reconnect and see if it resets.
Customer: replied 6 years ago.

are you talking about the radio screen?\

the radio works

also i found a power booster on this

would it cause a problem?

Yes absolutely that's most likely the entire issue is it hard wired in?
Customer: replied 6 years ago.

it is hard wired to battery

the radio works fine and show up on display

Ok remove that booster and recheck fuses I'm sure this is the issue .
Customer: replied 6 years ago.

the booster is wired to the rear speakers

i checked the fuses under dash and they are good

i unhooked booster when i unhooked the battery cables and when i hooked the cables up i left the booster off still nothing works except the radiio

are there any fuses anywhere else i need to check

Customer: replied 6 years ago.
where is the fusible link box
Customer: replied 6 years ago.
i found 2 fuse boxes under hood and 1 on driver side inside car is this all
It's next to the under hood fuse.If there are no issues then gauge cluster itself is bad.
Customer: replied 6 years ago.
would that cause you to not be able to control a/c because a/c control panel does not light up or let you control a/c but a/c is on low blower
Customer: replied 6 years ago.
what is next to under hood fuse
Should be another fuse box with fuseable links.
Customer: replied 6 years ago.

found it beside battery and nothing blown

checked fuses in relay panel

could the relay panel be bad since the a/c panel does not light up or let you control a/c

Yes absolutely very common for these boards to short out and cause this issue . Alot of times it's from a coin that dropped. This would be the next item to check and most likely the issue. Hoped this helped .Positive feedback and bonuses greatly appreciated.
Tom and 4 other Car Specialists are ready to help you

Related Car Questions