How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask DoctorD Your Own Question
DoctorD, Auto Service Technician
Category: Car
Satisfied Customers: 685
Experience:  ASE Master, AAA State 1st place, Rotary Club, 20 years Exp.
Type Your Car Question Here...
DoctorD is online now
A new question is answered every 9 seconds

2002 buick rendezvous: the awd disabled light is on, What

This answer was rated:

I have a 2002 Buick Rendevous and the awd disabled light is on, What are the causes of this and what action can be taken to repair it? Thanks in advance.


Many times you will have an AWD fault due to an ABS system fault, like a wheel sensor,ect.

The only way to diagnose is to have a professional scan done on the ABS and AWD modules. The parts store computers cannot access these models. Usually a "good" independent or the dealer will have a Tech2 computer to diagnose this for you.

There are just too many things that is may be, but I would say by far its a Brake system fault causing the light.

Customer: replied 6 years ago.

the antilock light is on, it came up as lf and left rear wheel sensors. I had both hubs changed and it is still coming up lf sensor is bad. Could it be the wiring, and i have excess to a modis scan tool, will that do it???

do you happen to have fault code #'s for me?
Customer: replied 6 years ago.
No i dont, sorry. I cant remeber what it was but i can get it tomorrow morning.

ok, that would help greatly. I have seen many problems with the connectors corroding at the hub. And some wiring problems as well.

If you can get me some codes, I can narrow it down for you some.


Customer: replied 6 years ago.
The code is C0035 lf wheel sensor. There is power going to the bearing itself and the bearing itself is new.Thanks


Here is the bulletin I was after as I copied below. Now since you have replaced the effected hub already with the condition still present, Or I assume the condition is still active? It takes a special scanner to erase ABS codes. If the condition is still current I want you to purchase a connector pigtail for that hub which is the drivers front, and replace that connector with the wire kit available through Acdelco.

That should fix your problem>


Bulletin No.: 03-05-25-004A

Date: April 14, 2004


ABS and/or Traction Control Lamp On, AWD Disabled Message Displayed, DTCs Set (Replace Front Wheel Bearing and Hub Assembly)


2002-2004 Buick Rendezvous
2002-2004 Chevrolet Venture
2002-2004 Oldsmobile Silhouette
2002-2004 Pontiac Aztek, Montana


with All Wheel Drive


This bulletin is being revised to change part number information and update the model years. Please discard Corporate Bulletin Number 03-05-25-004 (Section OS - Brakes).


Some customers may comment that the ABS and/or traction control system lamp is illuminated. Also, the AWD disabled message may be displayed. Upon investigation, the technician may find several DTCs set.


When normal diagnosis leads to the wheel speed sensor as the suspect component, replace the front wheel bearing and hub assembly, P/N 89047684. Refer to the Wheel Bearing/Hub Replacement procedure in the Front Suspension sub-section of the Service Manual. This new part has 6 mm (0.236 in) added to the harness to prevent any stress to the wiring.



Parts Information

Parts are currently available from GMSPO.

Warranty Information


Customer: replied 6 years ago.
Ive tried to erase the abs code and it says codes cleared successfully but it doesnt shut off the light. Does it have to be a dealer scan tool?? Also, the sensor is new on the hub. Do you want me to splice the wires, or does the pig tail come with connectors on each end?? Thanks again!
I am pretty sure you have to have an up-level scanner to clear ABS codes. Not only dealers have them, A good independent shop should have one. I would like you to pursue this first as you may have already fixed your car with the new hub. But if we are doing the new pigtail, it comes with splices and heat-shrink tubing to cut the wires and make a good splice. Lets erase those code(s) first and see what happens!
DoctorD and other Car Specialists are ready to help you
Customer: replied 6 years ago.

Ive tried to erase the codes and on the data stream the lf wheel bearing is still reading zero while the other three are doing the job there supposed to. I am going to see if i may have damages the sensor when i put it is>


yes "0" is not good. Check connection real good, if good we will need to check your new speed sensor to see if it works.

Related Car Questions