How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Paul M ASE Master Your Own Question
Paul M ASE Master
Paul M ASE Master, ASE Master Tech
Category: Car
Satisfied Customers: 4683
Experience:  Ase Master 20+ Years Experience Foreign and Domestic
28939717
Type Your Car Question Here...
Paul M ASE Master is online now
A new question is answered every 9 seconds

1992 Mazda 929: No Start Condition..See A Check Engine Light Flashing

This answer was rated:

Hi, Guys. Im Working On A 1992 Mazda 929. No Start Condition, I Have Pulse Coming From The Distributtor I Tried To Retieve A Code But I Dont See A Check Engine Light Flashing. I Only See A Light That Says Hold Blinking Continusly, By The Way, The Car Came Into My Shop With The Timing Belt Popped.

Hello and thank you for using Just Answer

 

does the engine light light when you turn the key foward for the bulb check?

 

are you jumpering pin 10 to ground?

 

Paul

Customer: replied 6 years ago.

yes 10 to ground but the check engine ligth is of all the time

Looks like you have a bad bulb because it should come on when the key is first turned on for the bulb check

 

I would replace the bulb and recheck for codes

 

Paul

Paul M ASE Master and 4 other Car Specialists are ready to help you
Customer: replied 6 years ago.
if the bulb is fine, what do I check next?

the light is powered by the ECU

 

so if the bulb is good and you have good ground to the cluster. and the gray/black from the ECU is good the ECU or the cluster is faulty

 

click here for the ECU wiring

 

Paul



Edited by Paul M ASE Master Technician on 6/2/2010 at 1:45 AM EST
Customer: replied 6 years ago.

ok thanks for you help my secretary is goin for today(my litle douther)

she write inglis better but i goin to try.

check engine ligth is off even whith key on

i take the dasboard of the car and the bulb is ok

but i find the wire from the bulb to computer grey and black are no conected i check whith my omiter and is cut ,

the signal coming from the computer in wire grey / black key off - key on +

questioon is this cable goin somwere firts before goin to check bulb

 

My diagram shows it runs directly from the ECU to the CLUSTER

 

Paul