How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask jeepmopar76 Your Own Question
jeepmopar76, ASE Master Tech
Category: Car
Satisfied Customers: 2144
Experience:  32 yrs ASE Master tech, 9 yrs Chrysler Master Tech, 19 yrs w Jeep + AMC, & 13 yrs w Dodge, Chrysler
Type Your Car Question Here...
jeepmopar76 is online now
A new question is answered every 9 seconds

Dodge Ram 1500: 4.7L..hesitation..transmission control

Resolved Question:

Dodge Ram 1500 4.7L 2003 127000km. When driving on the hiway at any speed if I step on the gas slightly feel hesitation on and off almost like when sparkplug wires are crossed. I was thinking maybe my transmission fluid needs changing as it has never been done but every thing seems fine in town driving or on cruise control. The problem was only present at excelleration. I just had a new battery enstalled a few weeks ago when it would not start on a very cold day. I would not even start with a boost. I had an engine light on that said a small evap leak was present. They said a hose needs replacing. They shut the light off and it never came back on then the rough driving started. Do you think the evap leak could be causing my problem? Now this afternoon my truck wont start and I even plugged it in. Hope you can help. Thanks! Kevin
Submitted: 6 years ago.
Category: Car
Expert:  jeepmopar76 replied 6 years ago.

There are no plug wires on your motor, but I bet new spark plugs would help your motor. I would also try some spray cleaner down the throttle body to clean the entire induction system and valves. The plugs on your motor should be changed after 30,000 miles.

An evap leak will not cause a running problem, or miss.

jeepmopar76 and 10 other Car Specialists are ready to help you
Customer: replied 6 years ago.

I had new high end irridium plugs put on just 40 thousand km ago. Do you think that would be causing that? Maybe one is faulty or not firing properly

Expert:  jeepmopar76 replied 6 years ago.
My expereince with Dodge engines, is that they do not run good on plugs that are any thing but Chanpion plugs ment for the motor. I would try installing the correct champion plugs. Good luck
jeepmopar76 and 10 other Car Specialists are ready to help you

Related Car Questions