How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. Your Own Question
Lou P.
Lou P., ASE Certified Technician
Category: Car
Satisfied Customers: 3663
Experience:  I Have knowledge in almost all car lines and can help with general questions and more!!!!!
Type Your Car Question Here...
Lou P. is online now
A new question is answered every 9 seconds

99 Buick Park Avenue, it runs smooth for 3-5 min. and it shuts off.

This answer was rated:

I have a 99 Buick Park Avenue, it runs smooth for 3-5 min. and it shuts off.



when the engine dies does it just shut off or does it start to run bad before it dies.??

Customer: replied 6 years ago.
im sorry but i asked you 2 different questions. does it run bad then die or does it just quit?. please be specific i really want to help but i need to get a feel for the car.
Customer: replied 6 years ago.
yes,it runs rough before it cuts off.
ok have you tried giving it gas to see if you can keep it running??
Customer: replied 6 years ago.

yes, I can pat the gas to delay it but it will cut off. I try to crack it back up but it dies.


ok try and unplug the mass air flow sensor and see if it runs it may take a few times to get it started with the sensor unplugged but when it starts see if it will stay running on its own.also are there any fauttcodes is the check engine light on??
Customer: replied 6 years ago.

no codes in the computer. If I let the car sit for a minute it starts fine for about 2 minutes then studders and high idle up and down then cuts off.


ok did you try to unplug the mass air flow sensor like i suggested??
Customer: replied 6 years ago.



ok so did it run or no???? also does it sound like its sucking air like a vacuum leak when you get it started??
Customer: replied 6 years ago.
not in front of the car now. so what are the choices?
ok mass air flow sensor is reasding incorrectly not allowing the car to idle correectly. a pcv vavle or line in the rear vavle cover that comes ;loose letting in extra air at idle. or a map sensor not reading correctly. your bound to find a problem with one of these since you coverd the fuel and spark issue.hope this helps.,
Lou P. and 7 other Car Specialists are ready to help you
Customer: replied 6 years ago.
not saying no but it run perfect when cold . Ican reve it up to 4000 rpm and let up and it idle smooth. Key when cold .
ok without you near the car to try a few steps thats as far as i can comfortably guess and i do not like recommending parts unless im ceratin its gonna help you out. you pretty much have the ignition system and fuel syste, covered so it tells me its just a sensor reading bad. a coolant temp sensor would actually do the same if it thinks its cold when the engine is warm it will flood itself. so now we got possible coolant temp sensor, mass air flow sensor, map sensor or vacuum leak.

Related Car Questions