How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee, Former ASE Master Tech
Category: Car
Satisfied Customers: 24093
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
Type Your Car Question Here...
Amedee is online now
A new question is answered every 9 seconds

i have a 99 galant my wipers dont work checked fuses all good

Customer Question

i have a 99 galant my wipers don't work checked fuses all good change wiper motor and a new wiper switch still dont work what can be the problem
Submitted: 6 years ago.
Category: Car
Expert:  Amedee replied 6 years ago.



You very well might have a bad new wiper motor. However, you will still need to diagnose this problem. Key on and wipers on check for voltage with a multimeter at the connector. Here a hint. A lot of times it is a bad ground. Do a voltage drop from the outside of the motor casing to the negative batt post while the wipers are on. if it is more than .5 of a volt than the motor does not have a sufficient enough of a ground to work. If so the connections will have to be cleaned and tightened up. Good luck!

Customer: replied 6 years ago.
i had a mechanic put a meter on it and he said it had voltage and was the wiper switch i replaced the switch now still have nothing when he put the meter on it he did something and the wiper worked
Expert:  Amedee replied 6 years ago.
Yeah... most likely he bumped the wiper motor and the the ground connections made contact and the wiper motor started to work. I see this all the time!
Customer: replied 6 years ago.
how do i fix this
Expert:  Amedee replied 6 years ago.
First... you diagnose.. to see if this is in fact the problem. If it is, then you just unbolt the wiper motor and clean the connections where it mounts to and re attach to the vehicle nice and tight and it will work.

Edited by AMEDEE on 12/1/2009 at 12:43 AM EST
Customer: replied 6 years ago.
but why did he tell me i needed a new wiper switch
Expert:  Amedee replied 6 years ago.

Thats a good questions. I am not sure. I would ask him that.


Probably because he had no idea what was going on.

Customer: replied 6 years ago.
is there some type on wiper relay some where
Expert:  Amedee replied 6 years ago.
Yes... there are two. But if the wiper motor was getting power, then the relays should be good.
Customer: replied 6 years ago.
where are they located in a galant
Expert:  Amedee replied 6 years ago.




Customer: replied 6 years ago.

so you said there are two one in front b ecu where is the second

Expert:  Amedee replied 6 years ago.
They are both in the front ECU
Customer: replied 6 years ago.
so should i replace the ecu with one from the junk yard
Expert:  Amedee replied 6 years ago.

Not unless its bad.

Customer: replied 6 years ago.
ill try the things u told me and ill get back to u tomorrow
Expert:  Amedee replied 6 years ago.

I hope this helps. You can always accept my answer now, and repost back again later on if you have any more questions. If you want to discuss it some more just hit "reply", it's free to do so otherwise don't forget to hit "accept" and leave positive feedback if you found my answer helpful.