How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mikehatch Your Own Question
mikehatch, mechanic/technician
Category: Car
Satisfied Customers: 160
Experience:  I have worked in the automotive industry for 32 years.
Type Your Car Question Here...
mikehatch is online now
A new question is answered every 9 seconds

2001 Oldsmobile Aurora replaced bad battery and let the car

Resolved Question:

2001 Oldsmobile Aurora replaced bad battery and let the car set for 5 days and battery went totally dead. The lights won't even come on. Any idea what drained the battery
Submitted: 6 years ago.
Category: Car
Expert:  mikehatch replied 6 years ago.

Hello my name is MIke,

You stated that the battery post was corroded, which post was it? It seems odd that the accessory shutoff relay would allow the battery to be drawn down to the point of being flat. Was the battery a fully charged unit or did you get a battery that had little or no charge. How far did you drive in those couple of days after you installed the battery?

Let's see if we can find an answer to your problem.

Thanks, Mike


Customer: replied 6 years ago.
It was the Positive I believe my husband worked on it. I drove it to town and my daughters and probably 45 miles altogether. I bought the battery form O'Riellys and they had to order it in on the truck beccause they were out in the store. When my husband put it in it cranked right up.
Expert:  mikehatch replied 6 years ago.

Hello Again,

I would have the battery recharged and tested at ORielly's. Its possible the battery could have had a low charge. Also I would double check that the cable and/or the battery terminal is tight and that all the connections or wires are connected and tight.

I believe it a good possibility that the battery was low charged and caused your problem.

If i have answered your question please accept my answer.

If I can help you further please let me know.

Thanks Mike

mikehatch and 7 other Car Specialists are ready to help you
Customer: replied 6 years ago.
Sorry He hasn't had the chance to even look at the car we had a doctors appointment 150 miles away and just got home .
Expert:  mikehatch replied 6 years ago.

Good MorningCustomer

Thanks for the update. So when your husband has a chance to recheck the cables and should check the other cable and terminal also to make sure it is corrosion free also. Let me know what happen with the battery and whether there were any wires or connection loose at the battery?

Thanks for using Just


Customer: replied 6 years ago.
The Battery was bad. It wouldn't take a charge. Thanks

Related Car Questions