How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Auto Service Tech
Category: Car
Satisfied Customers: 29427
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Car Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

1999 oldsmobile silhouette: the spark plugs and wires fuel filter

Resolved Question:

i have a 1999 oldsmobile silhouette mini van with the 3400 engine with 180000 miles when i start the car it wont stay running unless i give it a little gas for like 6-7 seconds then i can let off and it will stay running it now also misses really bad when driving down the road after the engine worms up the rpm gauge jumps all over the place and when it does then it chugs really bad i have no idea were to turn i have replaced the throttle positioning sencor the mass airflow sencor the spark plugs and wires fuel filter the fuel pump is at the right psi i also have a service engine light on indicating the crankshaft positioning sencor witch i have replaced twice now and cleared the code 10 times and continues to come on i also unhooked the batterie three times to help the computer learn the new crankshaft censor i also had the ignition modual under the coil packs tested and was fine so put back in so im not sure were to go from here if you have an answer that would be great thanks. Andy
Submitted: 7 years ago.
Category: Car
Expert:  GM Tech (Cam) replied 7 years ago.

Welcome to Just Answer and thank you for asking your question. I look forward to helping you fix your vehicle.

 

I will try my best to help you and in order to do that, I need you to describe the issue in as much detail because I only know as much about your vehicle as you have told me in your post, so my answer will be based on what you have posted. Please include all the small details that may seem insignificant such as warning light or noises.

My goal is your satisfaction and I ask that you not accept unless you are satisfied, but if you are satisfied, please accept so I can receive credit for my work and time. Positive Feedback is greatly appreciated and bonuses are always welcomed.

 

Please feel free to reply as needed.

Which sensor did you replace, There are 2 for the crank. One under the harmonic balancer, and one on the back off the engine block. Also do you have a remote starter installed? Often the wire for the tack is tapped into the speed signal at the ignition module, and that being too close to the spark plug wires can cause an issue like this.

Customer: replied 7 years ago.
i do not have a remote start i replased the one by the harmonic balancer and the rpm gauge at first only jumped when i turned the stering wheele to the left from top dead center then after a few weeks it jumps now both ways on the wheel but drives just fine when the wheel is turned farther to the left and right
Expert:  GM Tech (Cam) replied 7 years ago.
OK, I would then check the crankshaft position sensor that the back of the engine. Check also wiring that goes from the ignition module down the driver's side of the module to the sensor. But this is also in the proximity of the steering gear, and steering shaft.
Customer: replied 7 years ago.
so theres a wire that goes from the egnition modual to the back sencor of the block. i also was wondering about the fact that i never had a service light on when it wouldent stay running when you first start cold or hot im just curios if that is some how conected to all of this
Expert:  GM Tech (Cam) replied 7 years ago.
It could very well be. THe readings the computer may be getting are valid, but do not cause the engine to run properly. Also could the check engine light be inoperative? Do you see it when you first turn the key on?
Customer: replied 7 years ago.
ya i do see the light on when i start it and i have had the code erased like ten times would the crank shaft censor make my rpm gauge jump like that
Expert:  GM Tech (Cam) replied 7 years ago.
OK. I would still suggest checking all these sensors and wiring. Disconnect the connectors and see if there's oil in there.
GM Tech (Cam) and 10 other Car Specialists are ready to help you

Related Car Questions