How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim West Your Own Question
Tim West
Tim West, ASE Certified Technician
Category: Car
Satisfied Customers: 4638
Experience:  ASE Certified Service Manager for Bridgstone/ Firestone
9949505
Type Your Car Question Here...
Tim West is online now
A new question is answered every 9 seconds

93 mazda: vacuum lines..its rev when its in nuetral and park..guage

Customer Question

93 mazda rx7 im having a spuddering problem!! at 3,000rpm - 3,000rpm it spudders and wont go any higher this is if u stomp on the gas if ur driving normal it doesnt have a problem its got new vacuum lines in it and i think the person who owned it before me might have cross vacuum lined it. it also fluxuates its rev when its in nuetral and park. and the oil guage fluxuates like crazy when u stomp on the gas what could the problem be????
Submitted: 7 years ago.
Category: Car
Expert:  Tim West replied 7 years ago.
Thanks for visiting JA.com
Is there a check engine light on? Do you know if any codes are stored?
Let's check for vacuum leaks. Using starting fluid, or a combustible spray, spray the engine area down with the vehicle running. If the engine responds to the external fuel you probably have a vacuum leak.
Try unplugging the mass air flow sensor located on the air hose coming out of the air filter box.
Let me know how this goes.
Customer: replied 7 years ago.
i just talked to my ssgt he works at auto zone he heard my car and gave me a call after i left and he thinks its a cross spark plug wire connection or maybe not a hot enough spark u think that could cause the problem
Expert:  Tim West replied 7 years ago.
Nope, cause when you hit the gas the problem goes away. A misfire will run badly all the time.
Customer: replied 7 years ago.
and no no check engine light is on and the vacuum hoses have been replaced because they are red not the standard black ones they come with and when i looked under the hood there was an open vacuum line thats where i was getting the idea of messed up vacuum lines

Expert:  Tim West replied 7 years ago.
No a bad thought. Did you try unplugging the MAF and checking for other vacuum leaks?
Customer: replied 7 years ago.
not yet i am putting all new after market turbo kit in it next week and i was going to go through a vacuum diagram and see the ones i am missing and connected wrong
Expert:  Tim West replied 7 years ago.
Ok, well let me know.

Related Car Questions