How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1044
Experience:  16 years of experience
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

1980 lincoln continental: the bright light comes..wiring harness

Customer Question

I have a 1980 lincoln continental mk6 the problem is my instrument cluster on the right side of it is not working or the key board to when you pull the light switch out the ligts in the key board come on and on the cluster the bright light comes on but thats it I checked for power on the wiring harness the plug for the cluster is getting power but there is no power at the push buttons unless you put lights on I have 4 new clusters i put in but still nothing I think it feeds off of the buttons I am a mechanic also but im just not sure whats going on It used to work ok at one time i did noticed the read out on that one side getting dim im not sure what powers the key board
Submitted: 7 years ago.
Category: Car
Expert:  danny replied 7 years ago.
I think I am understanding you right that you have power and new clusters but they dont work is that right?
Customer: replied 7 years ago.
danny thanks for getting back to me there areabout 6 wires in that connection only one has power to it now the key board dont have any power to it something is not giving the key board power . when i put the lights on the numbers light up there are 2 seperate power plus for the cluster when the lights are on and you put on the bright lights on that ligts up in that section this cluster has 3 sections left side is gas level middle is speedo the right is temp,clock door ajar i put about 4 different clusters in and same results power has 2 come from the key board to read temp and clock and ect. i dont know what powers the push buttons if you would like to call me that would be ok
Expert:  danny replied 7 years ago.
Have you chase the wires down for shorts and checked fuses. - have to ask everyone.
Customer: replied 7 years ago.
yes all fuses are good and ive been tring to trace the wiring for the push buttons do you have wiring diagrams to find out what feeds the push buttons maybe the computer or a relay
Expert:  danny replied 7 years ago.
I will look in my resources and get back with you.

Related Car Questions