How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MCVGreg Your Own Question
MCVGreg, Master Troubleshooter
Category: Car
Satisfied Customers: 7950
Experience:  25 + Years Working with Cars & Electronic Control Systems
Type Your Car Question Here...
MCVGreg is online now
A new question is answered every 9 seconds

2001 Olds Aurora: OBDII..Catalyst..Evap..I have driven 350 miles they

Resolved Question:

2001 Olds Aurora 4.0 OBDII Readiness Monitors Catalyst and Evap Sys read not ready I have driven 350 miles they won't reset what next?
Submitted: 7 years ago.
Category: Car
Expert:  MCVGreg replied 7 years ago.

Hello & Welcome,


Do you have a check engine light (or service engine soon) on, or is it reading the "not ready" at an inspection site?



Customer: replied 7 years ago.
The Check engine light was on. Tunex Replaced the secondary air motor which the code said was wrong. They reset the computer, but now I get two not ready reports
Expert:  MCVGreg replied 7 years ago.

OK - Thanks for that information.


The key to making the vehicle "ready" is to drive it under certain conditions so that the proper tests will run and record a "pass" in the computer. I have a chart below that might help you do this. One main key is to make sure that you start with a fully cold engine. You might also want to do these drives over a couple of days, just to be sure. Give this a try and let me know what happens.




Here is the same thing in a different format.




And one last format.




I hope this helps. Please let me know how it goes.


Take Care, Greg A.


P.S. Do not reset the computer or you will have to start the process over, as that clears out the readiness indicators too.

MCVGreg and 9 other Car Specialists are ready to help you
Customer: replied 7 years ago.
MCVGreg I had the Olds Aurora last week. over the week end I found a country road and performed the tests you suggested. I did it twice. It worked. Thanks for your suggestion. Gordy Holt West Jordan Utah
Expert:  MCVGreg replied 7 years ago.

You are quite welcome, glad I could help.


Take Care, Greg A.

Related Car Questions