How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Car
Satisfied Customers: 7184
Experience:  Since 1975
12769047
Type Your Car Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

1995 olds: park..soon light comes on,clean key..temperature gauge

Customer Question

I have a 1995 Olds aurora.The problem that I'm having is that the car is raceing. The rpm's go from 700 to 2000 while in park,the service soon light comes on,clean key in 3 minutes,temperature gauge is flashing. While I was driving ,I stepped on the gas and the engine raced the rpm's went up to45oo. I tried to reset the computer by disconneting the battery. Now the car does not start at all......help
Submitted: 7 years ago.
Category: Car
Expert:  rpmdiag replied 7 years ago.
Customer

 

Let's try this first; Disconnect the battery for 20 minutes and touch the 2 cable ends together for a few seconds. Then re-connect the battery and start and drive car immediately for 20 minutes at idle, cruis and wide open throttle. Keep me posted of the results!

 

Thanks for your question and positive feedback,

 

Ron

Customer: replied 7 years ago.
Hi........ The car started ,I drove the car for twenty minutes. It stalled once, it would not get out of first gear. If I stepped on the gas to go faster to shift , the engine would race. Then when I shut the car off , the air shocks would continue to run ,the radiator fan started to run ,and would not stop so I pulled the negitive battery cable off. Also three months ago I had the TRansmissiom replaced.
Expert:  rpmdiag replied 7 years ago.

Okay, we made some progress here. If the check engine light came on let me know. The tranny shop needs to be notified of this now too.

 

Thanks again,

 

Ron

Customer: replied 7 years ago.
hi......Two message lights did stay on no traction and anti-lock brakes... Thank you
Expert:  rpmdiag replied 7 years ago.

Understood, that's why we need to scan the computer to see what it tells us for codes in those modules. Also, I can still help you after you have ACCEPTED.

 

Thanks again,

 

Ron

 

 

rpmdiag and 7 other Car Specialists are ready to help you
Customer: replied 5 years ago.
I wrote the other day wednesday. I disconnect the battery because the car sits for a month or two. Now the rpm go from 500 to a1000. It fluxulates even on cruise.I sprayed the throttle body with wd-40 thought maybe that would help.So the answer that you are giving me is from a old question. The answer that was given . was a sensor on the throttle body.... thank you

Related Car Questions