How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee, Former ASE Master Tech
Category: Car
Satisfied Customers: 24127
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
Type Your Car Question Here...
Amedee is online now
A new question is answered every 9 seconds

Kia rio: shifts hard.and when it wont start scanner wont work

Customer Question

hi i have an 02 kia rio that somtimes wont start.somtimes shifts hard.and when it wont start scanner wont comunication.when it does start no prob with scanner..have you seen this.....
Submitted: 7 years ago.
Category: Car
Expert:  Amedee replied 7 years ago.
Sure... when this happens, does the check engine light come on with the key in the on position?
Customer: replied 7 years ago.
yes it does and thats why i belive it has power to the not sure what to doo
Expert:  Amedee replied 7 years ago.
DO you have a reference voltage to the sensors with the key on under the hood when this happens? Like the TPS sensor?
Customer: replied 7 years ago.
mmm not sure....hard too tell some times it starts an some times it dont.i was hopin you had this problem before..
Expert:  Amedee replied 7 years ago.

Oh... I have... many times. It could be several things. Thats why we need to check for a references voltage to the tps sensor when this happens.

Customer: replied 7 years ago.
ok i can in the morning ,what should i look for?
Expert:  Amedee replied 7 years ago.
Well the TPS sensor should have a reference voltage of about 5 volts with the key on. Remember, you should check this when the problem occurs.
Customer: replied 7 years ago.

mmm. this is it im sure thats the case i will check it to be sure but the car runs fine when its fuel pump too eh..

Expert:  Amedee replied 7 years ago.

Ok... let me know about the reference voltage when you can.


I will be waiting.

Customer: replied 7 years ago.
sorry about that..ok one wire is 3.19 volts another is 12.7 volts and the tird is .713,i take it that one is a signal.and that is with the car not running
Expert:  Amedee replied 7 years ago.
Are you at the tps sensor? Is the key on?
Customer: replied 7 years ago.

no im not at the car but i checked it today and thats what happened

Expert:  Amedee replied 7 years ago.
Can you let me know what you find out?
Customer: replied 7 years ago.
what else do i check?i checked the voltage at the tps thats what it was..
Expert:  Amedee replied 7 years ago.
So none of the wires have 5 volts on them?
Customer: replied 7 years ago. has12.7 3.19 and .713...i should of got the color for each one..but thats what it is reading on the dvom
Expert:  Amedee replied 7 years ago.

Here is a wiring diagram. Lets make sure we are on the correct wires.



Customer: replied 7 years ago.
i should go back too the shop and check..i only seen one sensor on the throttle was on the opposite side of the throttle flap...ill double check but im sure..
Expert:  Amedee replied 7 years ago.

THe 3 wires to the tps are


White with green stripe


Blue with orange stripe


Blue with green stripe

Customer: replied 7 years ago.
hi...sorry your right i checked the tps and it is 5.12 volts..mind ya the big sensor on the throttle body is buzzing.....i think its the iac..
Expert:  Amedee replied 7 years ago.

Ok... good!


SO we have a reference voltage at the tps sensor with the key on when this problem happens but still no communication with a scan tool... correct? And the vehicle still wont start when this happens? Did we check the TPS sensor for the 5 volt reference when it wont start?

Customer: replied 7 years ago.

When I checked it for voltage, the car was not starting. Thought you might have had a quick answer.

Expert:  Amedee replied 7 years ago.



This is a tough one!


Ok... WHat I would like you to do, is check for spark and fuel. See if you have spark to the spark plugs when this happens. If you do, lets see if it runs on starting fluid.


Let me know!

Customer: replied 7 years ago.
do you mean either?
Expert:  Amedee replied 7 years ago.



If not, lets at least see if it will run on starting fluid.

Expert:  Amedee replied 7 years ago.



Have we had a chance to try starting fluid?

Related Car Questions