How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Car
Satisfied Customers: 7055
Experience:  Since 1975
12769047
Type Your Car Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

My car will start but wont stay running. Have replaced the

Resolved Question:

My car will start but won't stay running. Have replaced the fuel pump, throttle position sensor, mass airflow sensor, crankshaft position sensor, all 6 coils on the plugs and the plugs themselves. Anyone got any ideas?
Submitted: 7 years ago.
Category: Car
Expert:  rpmdiag replied 7 years ago.

Hi Customer,

 

Tell me what we're working on and if you have a check engine light on.

 

Thanks,

 

Ron

Customer: replied 7 years ago.
its a 2002 hyundai xg350. I bought it about 2 months ago. drove it for 2 weeks then it lost all power. Now it doesn't even run. The check engine light never came on but I think it was disconnected.
Expert:  rpmdiag replied 7 years ago.

Try spraying carb cleaner at it and see if it tries to stay running, if not, we may be losing spark or have a security problem. Possibly losing injector pulse from the computer also.

 

 

Rpn

Customer: replied 7 years ago.

doesn't stay running..

we've tried that

thought the butterfly wasn't opening up at one point

 

Expert:  rpmdiag replied 7 years ago.

Please respond with all items I mentioned when you post back, ie security system, spark loss and injector pulse loss. Have you checked for what we're losing when it won't stay running.

 

 

Ron

Customer: replied 7 years ago.

my mechanic says the fuel pressure is fine, what kind of security issue would it have, I do have the original stereo out, but this happened before I took it out. I don' t think there's any spark loss ill check with my mechanic and I don't know about the pulse loss either.. I'll make a call and see what he says.

 

Expert:  rpmdiag replied 7 years ago.

Cool, thanks.

 

Ron

Customer: replied 7 years ago.
He's not answering the phone.. Should I take the stereo down and put that back in the car? The only other thing that I've done is I've replaced the original headlights with hids, but all this was done after the car quit working. What about the camshaft sensor? I think thats the last one we have to replace.
Expert:  rpmdiag replied 7 years ago.

You don't need to replace everything between the bumpers, we need to dial in on THE problem. get done what I suggested first.

 

Thanks in advance for your ACCEPT!!!!!!!!!!!!

 

Ron

rpmdiag and 5 other Car Specialists are ready to help you