How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask 32dmadden Your Own Question
32dmadden
32dmadden, Auto Repair Shop Owner
Category: Car
Satisfied Customers: 1207
Experience:  A.S.E. Certified Master Technician, L-1 37 yrs. Auto Repair Experience
1361311
Type Your Car Question Here...
32dmadden is online now
A new question is answered every 9 seconds

91 cadillac deville: any vacume leaks..throttle body..pcm..exhaust

Resolved Question:

91 cadillac deville it started out with a slight miss 2 months ago and 2 weeks ago the miss got worse I was looking for a failing plug or wire Etc. and really did not get any difference pulling 1 wire at a time and not finding any vacume leaks at this time I looked down the throttle body and saw there are 2 little orfices about 3/8 dia. that are so clogged up with carbon that there was no way it can breathe I do not know where these lead so I did not want to just shove stuff down it so I used a shop vac and a drill bit by hand to unclog it and the miss seemed not so constant so I drove a couple more days and the water hose that comes across the back of the engine from the thermostat to the T sprang a leak I replaced it 50 miles later car quits replaced pcm and ran w/ exhaust off..replaced cat,&muffler runs but bad miss is still there not bad when excel. hard accel. from stop you can feel it or idle uphill tapping brake smoothes it out repl. wires plugs etc. Any ideas?
Submitted: 8 years ago.
Category: Car
Expert:  32dmadden replied 8 years ago.
I think you have some vacuum ports that are stopped up. You will need to pull the throttle body off to clean it correctly. I think that port goes to the MAP sensor so if it isn't getting the correct vacuum signal drivability problems can occur. Have you checked for codes in the computer? If cleaning the port doesn't help check for codes. If you have any let me know what they are. If the check engine light has not been coming on there are not any codes in the computer. Let me know if you need more help.graphicgraphic
Customer: replied 8 years ago.
Hi there, There are not any codes in the computer. I was kinda figuring that it has to have some kind of vacume issue. Where do the 2 little tubes that are down the throttle body go? I think they are actually pressed into the intake The best I can figure is that they go down into the exhaust ports on the heads like the heat riser on an old chevy but I am not sure. The exhaust was totally clogged so I figure the egr stuff is clogged too can the purge canister be clogged as well causing some problems?
Expert:  32dmadden replied 8 years ago.
The purge canister can have a vacuum leak but the purge valve solenoid is only activated when at higher RPMs. I'm not sure what tubes you are referring to. There are two metal lines that supply and return the fuel that is pumped from the tank. Have you remove the throttle body yet to see if that port is stopped up. At least check to see if you have good vacuum at the MAP sensor vacuum hose. If this is the problem it will cause a rich fuel mixture. Driven for a period of time this will lead to A STOPPED UP CAT. I have worked on a lot of Caddies with this problem. You probably found the trouble when you found the stopped up port in the T-body. You just need to go a little further to unstop the entire port. I'll be here if you need more help.
32dmadden and 5 other Car Specialists are ready to help you
Customer: replied 8 years ago.
Hi there,
Thank you for your help this just confirms my original diagnosis I have had very little time to trouble shoot and one thing after another kept going wrong that I had to replace to keep the car on the road I can definatley tell that the throttle body is most likely clogged I will take it off and clean it out in a couple of days and I am sure this will solve the problem. The tubes I am talking about are just below the throttle body pressed into the intake they are about 3/8 dia. and totally clogged up as well I have cleared them out some and it seemed to make a difference I just did not want to go shoving stuff on down into the engine since I don't really know where they lead to I am pretty sure that they would have to go down into the exhaust ports in the heads through egr somehow because the build up in the tubes is like the buildup that gets into the heat riser exhaust port in an old small block chevy. However It has to be therouly cleaned to properly perform I am shure this will fix my problem. Thank you for your time. Brian