How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JerryG Your Own Question
JerryG, Mechanic
Category: Car
Satisfied Customers: 47
Experience:  over 5 years experience in late model repair, 2000 to 2009
Type Your Car Question Here...
JerryG is online now
A new question is answered every 9 seconds

95 eclipse gs 2.0 dohc, cranks but no start, have spark fuel

Customer Question

95 eclipse gs 2.0 dohc, cranks but no start, have spark fuel pressure & injector paulse, replaced cam sensor, ck compression 125, when checking plugs fuel fowled, acts like out of timing for fuel & spark.
Submitted: 7 years ago.
Category: Car
Expert:  Kenny replied 7 years ago.

Have you checked the timing belt to make sure it hasn't jumped a tooth. This cars are notorious for this.







Customer: replied 7 years ago.
I have rechecked timing belt, I have done many timing belts marks line up. i'm thinking crank sensor or pcm possiable proplem.
Customer: replied 7 years ago.
What I need is a crank but no start flow chart, I have dealership experiance @ ford dodge & chevy as line tech, thank you just stumped on this one.
Expert:  Kenny replied 7 years ago.
I dont have a flow chart. But have you used a timing light to check the timing by grounding the pcm and turning the cam sensor.
Customer: replied 7 years ago.
cam sensor in fixed position & no timming marks on crank pulley to ck timing, dsi system with coil packs
Expert:  Kenny replied 7 years ago.

I think you right on your initial suspicion that the pcm may be at fault. Unfortunately this is very expensive guess. But I think you right.






Customer: replied 7 years ago.
Found problem after replacing crank sensor & testing fuel mfi & pump relays, spark plugs were allways fuel fouled, so cleaned plugs look down into cyclinders very wet, so cranked engine with plugs out put spark lugs back in & disconect fuel relays & cranked engine to dry out cyclinders hooked back up relays engine started cleared codes reck for codes none & no ck engine light. thanks Loren
Expert:  JerryG replied 7 years ago.
Im thinking its timing also, sounds to me that its 180 out. Make sure both dial pins on the cam is facing the same direction. Let me know..

Related Car Questions