How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike Your Own Question
mike
mike, bmw master tech
Category: Car
Satisfied Customers: 1162
Experience:  ase certified.. bmw master tech
13313167
Type Your Car Question Here...
mike is online now
A new question is answered every 9 seconds

2004 Hyundai Santa Fe: The crank position sensor is showing up bad

Customer Question

My son has a 2004 Hyundai Santa Fe. The crank position sensor is showing up bad. My husband is trying to fix it, but says it is hard wired. How does he replace it?   Timing belt was just changed 10,000 miles ago, so not that.
Submitted: 8 years ago.
Category: Car
Expert:  mike replied 8 years ago.
Hi first I need to know what engine is in it. Thanks mike
Customer: replied 8 years ago.
It is a 2.4L engine
Expert:  mike replied 8 years ago.

Hi the dealer wants to replace the timing belt because it has to be removed when replacing the sensor. There is also a balance shaft belt these belts break or loose teeth and destroy the sensor. You will not know untill you tear it apart. If not familar with this kind of job dont recccomend you can cause damage to your engine if the timing belt is not put back on correctly. Thanks mike here is the location it is not hard wired. Wire runs up acros valve cover.

 

 

 

Component Location

Customer: replied 8 years ago.
It is the crankshaft position sensor. What you described is not the sensor. The wires do not run across the valve cover. It is a sensor at the bottom of the motor and the timing belt does not need to be removed to reach it.
Expert:  mike replied 8 years ago.
Hi That is the cranks sensor at the bottom behind the cover. Yes the wire does run up as picture shows. The picture I showed you is that your engine?? Mike
Customer: replied 8 years ago.
I showed my hubby the picture you sent and he said that is not it. Sorry.
Expert:  mike replied 8 years ago.
Hi ok My first info request I asked what engine you have you said 2.4l I guess you dont have that engine?????????? Is it a 2.7 ????? Mike
Customer: replied 8 years ago.
Hubby helping neighbor right now, will have to ask as soon as he is back. sorry Frown do appreciate your help
Expert:  mike replied 8 years ago.
Hi please tell me the correct engine size and I can give you the correct information. Thanks mike
Expert:  mike replied 8 years ago.
have you found out what size?