How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee, Former ASE Master Tech
Category: Car
Satisfied Customers: 24129
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
Type Your Car Question Here...
Amedee is online now
A new question is answered every 9 seconds

My car 1995 Oldsmobile delta 88 royale Ls 3.8l starts when

This answer was rated:

My car 1995 Oldsmobile delta 88 royale Ls 3.8l starts when its cold and after 20 mins shuts down with aggatating motor and takes a while to start again.
Greetings! You could have a bad fuel pump. I would rec to check fuel pressure. Fuel injected cars are very fuel pressure sensitive. Fuel pressure is very important and must be within specifications! But if the pressure is low, it does not mean the pump is bad. A plugged fuel filter, a pinched line, and low voltage at the pump can contribute to low fuel pressure. All three must be check before replacing the pump! You can get a fuel pressure gauge at a local auto parts store for cheap.
Customer: replied 7 years ago.
Its starts up when it cools down though, and when you turnm the key the pump runs strong, it acts up and hesitates when it gets warmed up, when its cold it starts right up and runs great. Do you really think it would be the pump or maybe a sensor of some sort
TO be honest with you, it could be either!

We need to start by checking the fuel system. If fuel pressure is up to par, then me can move on to the electronics. If you want to start with the electronics first, be sure there is spark to the spark plugs when this happens. If not, you could have a bad crankshaft position sensor.
Customer: replied 7 years ago.
Yeah I am getting light blue spark to the plug modules, ok i will test the fuel pump do u have a pressure what it should be or how do i get that, I have been dealing with this for over 2 weeks its mind boggling
Sure you bet!

On the non supercharged motors, the fuel pressure should be at 48-55 psi

I hope this helps. You can always accept my answer now, and repost back again later on if you have any more questions. If you want to discuss it some more just hit "reply", it's free to do so otherwise don't forget to hit "accept" and leave positive feedback if you found my answer helpful.


Amedee and 8 other Car Specialists are ready to help you