How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask TJ the Tech Your Own Question
TJ the Tech
TJ the Tech, Technician
Category: Car
Satisfied Customers: 5
Experience:  20 years plus experience and domestic and import.
Type Your Car Question Here...
TJ the Tech is online now
A new question is answered every 9 seconds

2005 Mitsubishi Eclipse: stereo..It turns on, changes CDs etc

This answer was rated:

I no longer get sound from my 2005 Mitsubishi Eclipse stereo. It turns on, changes CDs etc., but no sound at all.

The 2005 was equipped with or without and amplifier which do you have?

Customer: replied 7 years ago.
I'm not sure. Where would the amp be located?


I am not sure on your vehicle, but most of the time it is located in the trunk mounted on the rear hat shelf. If you have an owners manual it may be able to help you. Fuse #1 is for the amplifier (left side of dash fuse panel) fuse 23, & 24 are for the radio. I would start by checking all fuses with a test light. Let me know what you find and I'll do my best.
Customer: replied 7 years ago.
I suspect that I do not have an amplifier. I don't have a rear shelf. If you open the hatch, there is a hinged, removeable cover that extends about fifteen inches back from the top of the rear seats. You can remove the cover and fold th seats forward to make room for cargo. So, unless the amp is behind the interior moulding, I do not have one.

I'll check the fuses per your suggestion.
What model Eclipse do you have?
Customer: replied 7 years ago.
2005 GSX

Okay, if you can remove your radio and let me know what kind of wires are plugged into it. Then we can go from there.

Customer: replied 7 years ago.
ok. My wife has the car but she should be back soon. When I last looked, there are several connections. Is there a specific bundle you are looking for?
Looking for a thicker cable with a DIN plug on it.
Customer: replied 7 years ago.
Yes, there is a thick blac cable with a DIN connector.

Thanks for the information. You do have an amplifier, that's what the DIN cable is for. Assuming that the 20 amp fuse (#1 in the left side of dash fuse block) the most likely cause would be the amplifier. It should be located under the passenger seat. I would start by looking at the connections on the amplifier making sure one hasn't become dislodged. There should be an 18 pin connector on the amp, if you have a voltmeter measure the voltage of pin #2 to ground and #10 to ground there should be 12 volts at both. Let me know what you get.


TJ the Tech and 8 other Car Specialists are ready to help you
Customer: replied 7 years ago.
Ok! Will do...
Customer: replied 7 years ago.
Excellent! The DIN cable came out of the amplifier. I plugged it in and everything works normal.


I will certainly recommend you!

Awesome glad to help!!

Related Car Questions