How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Fuhrmeister Your Own Question
Fuhrmeister
Fuhrmeister, ASE Certified Technician
Category: Car
Satisfied Customers: 202
Experience:  10 years experience as a mechanic. Everything except A/C systems.
9283220
Type Your Car Question Here...
Fuhrmeister is online now
A new question is answered every 9 seconds

I have a 1985 Alfa Romeo Spider Veloce. I have no power at ...

Customer Question

I have a 1985 Alfa Romeo Spider Veloce. I have no power at either fuel pump. I have checked the voltage from the ignition switch through the fuse box but cannot find 2 electrical units hooked in series between fuse box and 15 pin connector to fuel pump. The fuel pump in the tank is brand new. Please advise.
Submitted: 8 years ago.
Category: Car
Expert:  Fuhrmeister replied 8 years ago.

Hello,

Does your car have a fuel pump relay under the hood?

thanks,

Fuhrmeister

Customer: replied 8 years ago.
Where is the fuel pump relay located under the hood What does it look like & what color wires etc.
Expert:  Fuhrmeister replied 8 years ago.

They look like little black squares about one inch by one inch/

thanks.

Customer: replied 8 years ago.
the alfa romero is where i work in Brooklyn, conn I only work mon wed & fri thats why there is a delay in checking your reply I have checked the engine compartment & the only set of relays the wire colors don't match the wires in the wire diagram Please advise
Expert:  Fuhrmeister replied 8 years ago.

Were the relays you found labeled in any way?

Thanks.

Customer: replied 8 years ago.
Yes the both are the same #(NNN) NNN-NNNN30amp
bye the way this is my first time and I am not a computer user so bare with I will be glad to pay you if you can work me though this one it is driving me crazy. thanks
Expert:  Fuhrmeister replied 8 years ago.
Have you used an indicator light to check to see if there is power at the fuel pump connector?
Customer: replied 8 years ago.
Yes I have. Do you have a wiring diagram of the 1985 spider If you do you'll see that after the fuse box the green/black wire is supposed to go to two units one is labeled S26 and the other is unmarked In the legend there is no such number and the other one hasn't even got a name. Now I have checked for power out of the fuse box and the green/black wire has power. then the wire goes into this harness and I cannot find where it goes from there. If I jump the power to the pumps they will run but do not want to hot wire the pump that way.
Customer: replied 8 years ago.
Fuhrmeister
Been waiting for an answer? what gives?
Customer: replied 8 years ago.
Mr Fuhrmeister I was kind of hoping for a reply or something any sugguestions what to do?
Customer: replied 8 years ago.
I can't believe that you didn't give me an answer or anything to work on and yet you charged me. Could you recap what you told me that helped me with my problem???? Good luck with the $9.00 I guess you needed it more than I.
   But I could have used your services more than just once BBBBut that won't be happening.
Expert:  Fuhrmeister replied 8 years ago.

I opted out of this question a long time ago. You never accepted anything so your $9 should still be in there unless you asked somebody else the same question and hit accept button.

Thanks.