How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mazda Ed Your Own Question
Mazda Ed
Mazda Ed, Auto Service Technician
Category: Car
Satisfied Customers: 2223
Experience:  ASE Master Technician, Mazda Master Technician, GM and Ford factory trained. 15 years experience!
Type Your Car Question Here...
Mazda Ed is online now
A new question is answered every 9 seconds

98 saturn: 1.9 sohc, its got 140,000 mi..warmed..starts fine

Customer Question

I have a 98 saturn sc1 1.9 sohc, it''s got 140,000 mi. I just replaced plugs and wires, within a week the car had a hard time cold starting. Once it''s warmed up it starts fine. To try to fix the problem I put the old plugs and wires back on it, thinking that they may have been the wrong gap or the plug wires may have been faulty. I also disconnected the negative off the battery for about 5 mins or so to allow the computer to reset and still have the same problem.
Submitted: 8 years ago.
Category: Car
Customer: replied 8 years ago.
Relist: I still need help.
Expert:  Mazda Ed replied 8 years ago.


The first thing I would check is for any codes stored in the engine computer. Also, with a class 2 scan tool I would monitor the engine coolant temperature sensor to be sure it is telling the vehicle the correct temperature.

If there are no codes and the ECT is reading ok I would try starting cold with my foot on the gas pedal just slightly. If it works fine that way, I would thoroughly clean the throttle body and retest starting normally.


Related Car Questions