How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask autodoc_2000 Your Own Question
autodoc_2000
autodoc_2000, Auto Service Technician
Category: Car
Satisfied Customers: 2563
Experience:  ASE Master Tech w/ Advance Engine Performance
157591
Type Your Car Question Here...
autodoc_2000 is online now
A new question is answered every 9 seconds

1991 chevy lumina: new plug wires, coil packs..O2 sensor..fuel pump

Customer Question

1991 chevy lumina v-6 new plugs, new plug wires, coil packs and the thing that sits behind the coil packs. New O2 sensor and coolant sensor, new fuel pump and filter (six months ago). I'm going down the road and it just quits running! I tow it home, It will start and run for about two minutes then just stop. I replaced the fuel filter and the same thing. No sputtering or anything just stops. It will not crank for about five minutes, but then it cranks right up and runs for about a minute or two and stops. I went to the filter and disconnected the line from the tank side and turned on the key and the fuel pump pumped about a quart of gas. (As soon as it stopped) WHAT COULD CAUSE THIS?
Submitted: 10 years ago.
Category: Car
Expert:  autodoc_2000 replied 10 years ago.

You may be loosing the crank signal. The crnakshaft position sensor determines when the coils should fire and if they should fire. Here is a picture of the sensor.


autodoc_2000 and 4 other Car Specialists are ready to help you
Customer: replied 10 years ago.
Reply to autodoc_2000's Post: I bought the part and am in the process of installing it. (It takes 5000 tiny hands to do it)sic. If this takes care of the problem I'll release the money if not I'll let you know.

Related Car Questions