How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mechanic
Category: Car Electronics
Satisfied Customers: 26647
Experience:  17 years automotive training and experience.
14928985
Type Your Car Electronics Question Here...
Pete is online now
A new question is answered every 9 seconds

My pioneer avh-x7800bt screen is blank when it oprns,

Customer Question

hello my pioneer avh-x7800bt screen is blank when it oprns
JA: What's the make/model of your device? How old is it?
Customer: pioneer avh-x7800bt a littleovera year old
JA: How long has this been going on? What troubleshooting have you tried?
Customer: a couple of months. not sure how to trouble shoot
JA: Anything else you want the electronics expert to know before I connect you?
Customer: just that all of the controls work just not the screen. and sometime it wont turn on so i have to reset it to get it on
Submitted: 8 days ago.
Category: Car Electronics
Customer: replied 8 days ago.
the unit is actually an avh-x7700bt
Expert:  Pete replied 8 days ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

If you are able to reset it to get it to turn on and operate but there is an issue with the display itself the first thing that needs to be done here is to have the power and grounds checked to make sure these are connected properly at the back of the radio itself and that the correct power and ground signals are working at the back of the radio.Most likely they will be since it does reset and work properly ( except for the display).What causes this fault here that I have seen in several cases before is a fault with the radio itself internally.The circuit board acts up causing no display like you see here.If power and ground is present at the back of the radio then the radio itself needs replaced or removed and repaired by an authorized repair center.You might check with the facility you had purchased it from since it is just a little over a year old to see if there is any warranty on it.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete