How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Thomas Tullo Your Own Question
Thomas Tullo
Thomas Tullo, Car Electronics Technician
Category: Car Electronics
Satisfied Customers: 22
Experience:  Owner at Auto Options
75484377
Type Your Car Electronics Question Here...
Thomas Tullo is online now
A new question is answered every 9 seconds

Having trouble with aftermarket radio.

Customer Question

Having trouble with aftermarket radio.
Submitted: 8 months ago.
Category: Car Electronics
Expert:  Don 'Mo Lurch' replied 8 months ago.
.sorry for the delay.............Greetings...... “Hi, I’m Don (aka MOLurch) and I look forward to helping you!”.I would like to help, but you have not posted:Year, Make & Model of Vehicle?what the Issue is?what is your question?I have seen the picture.IF you need more information, please ask "prior" to Rating..Please do the right thing and leave a rating, using the rating system, so I may be credited for this Q&A..NOTE: Do NOT Rate on how much TIME you waited, because I am not on 24 / 7 and I answer as soon as I see the question.The question will still remain open for follow up questions if needed..If for any reason, you can't rate my answer OKAY, GOOD, or EXCELLENT today.Please reply and let me know why, so I can help more/better..Rating is very Important to our Service.
Customer: replied 8 months ago.
Its a 2012 gmc sierra. It won't power on and I'm not sure what connections I am missing.
Customer: replied 8 months ago.
The harness came wired already with the radio so I just needed to plug in the connectors. Do I need to wire something to the ignition?
Expert:  Don 'Mo Lurch' replied 8 months ago.
Is there any loose wiresRED, RED / WHITE or YELLOW?What is the Brand & Model Number of the New Unit?
Customer: replied 8 months ago.
No loose wires. I bought it off eBay http://m.ebay.com/itm/301885678999
Expert:  Don 'Mo Lurch' replied 8 months ago.
I am not familiar with the DATA Module, as that is not a popular USA brand & have no info.Try this:Key OFFLeave Radio plugged into Factory HarnessUnplug the DATA ModuleTurn Key to ON & wait for apprx 1 minuteTurn Key OFFPlug the DATA Module inTurn Key ONDO NOT turn Unit Onwait for apprx 1 MinuteTurn Unit ONLet me know what happens
Customer: replied 8 months ago.
When you say unit what does that mean?
Expert:  Don 'Mo Lurch' replied 8 months ago.
sorry...........Unit = the New Radio that you have
Customer: replied 8 months ago.
Didn't turn on.
Expert:  Don 'Mo Lurch' replied 8 months ago.
thank yousorry for the trouble........At this point I will OPT OUT & RELIST this question, to see if someone else has seen this ModuleTypically it is Plug & Play & I am surprised that the Instructions did not walk you thru thatPlease do not reply to this, as it will Lock QuestionIF someone else can help they will post hereOTHERWISE........You should contact the Seller & have them walk you thru the Installationthanks.
Expert:  Thomas Tullo replied 8 months ago.
Hi my name is***** will try and help youfirst do you have a test light?
Customer: replied 8 months ago.
No
Expert:  Thomas Tullo replied 8 months ago.
Does the Original radio power on if it does then since you can't test anything i would return it to were you bought it. sorry i can't help more. it's plug an play so it should have worked, but there are a lot of variables.
Expert:  Thomas Tullo replied 8 months ago.
Please consider a positive rating. it is very important to them that we get 5 star rating.

Related Car Electronics Questions