How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Your Own Question
Michael
Michael, Technician
Category: Car Electronics
Satisfied Customers: 9133
Experience:  Over 25 years experience in the field of electronics repair, TV, VCR and computer repair.
11519491
Type Your Car Electronics Question Here...
Michael is online now
A new question is answered every 9 seconds

My hardware buttons do not light up on my avic z150bh

Customer Question

My hardware buttons do not light up on my avic z150bh
Submitted: 7 months ago.
Category: Car Electronics
Expert:  Michael replied 7 months ago.
Hi, I am Tech Michael an expert in this field and I will be assisting you today. I am a Master Technician that's dedicated to giving you the best Answer possible.If you are new to the site, this is briefly how it works:1. We may need some back and forth to exchange information (if needed) and there is no extra cost for replying.2. I will give you the best possible Answer for your problem without the ability of actually being present with you.The better you describe the problem, the quicker I can help ;-)3. Remember to leave a Positive Rating ,it doesn't cost anything additional to rate kindly;-)I am only credited for my time and expertise if you rate kindly.How old is your Pioneer Avic?Also when did this seem to fail in this way, and does it still operate normally except for lights out?Thank youTech Michael
Customer: replied 7 months ago.
Hi. My radio is 2 1/2 yrs old. Everything works fine. This problem happened 3 months ago. At one point it came back on then went out again.
Expert:  Michael replied 7 months ago.
Thanks for that information.Yes this is a known issue with this model.The trouble is caused by a defective electrolytic capacitor thats why it will sometimes work intermittently.Unfortunately this one requires service to fix this issue, but it is well worth the cost as the part is really inexpensive.You can take that to any local car audio shop for this fix, and Sears also will take this one in and send it out for this repair, it takes about two weeks through them.I wish I had better news for you , I really do.In any case, I will stick with you until this is complete.Please rate my service thus far.Also it is the only way I am credited for my time and expertise with you.Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.Then you can reach me by simply replying to this message anytime.Thank youSincerelyTech Michael